Last Comment Bug 678060 - Fix c++0x initializer list error found by clang
: Fix c++0x initializer list error found by clang
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla8
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 14:30 PDT by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2011-08-12 07:58 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix build (2.52 KB, patch)
2011-08-10 14:31 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
jaas: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-08-10 14:30:49 PDT
Fix build with clang and c++0x.
    ThemeMenuState is defined with a typedef from an integer type, not as an
    enum. Because of that, we need to add explicit casts when "assigning" to
    it in an initializer list.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-08-10 14:31:15 PDT
Created attachment 552218 [details] [diff] [review]
fix build
Comment 2 Daniel Holbert [:dholbert] 2011-08-11 15:24:54 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/059713859dcc
Comment 3 Matt Brubeck (:mbrubeck) 2011-08-12 07:58:50 PDT
https://hg.mozilla.org/mozilla-central/rev/059713859dcc

Note You need to log in before you can comment on or make changes to this bug.