Auto insert Mozilla build number into Description when reporting bugs with Mozilla

RESOLVED WORKSFORME

Status

()

bugzilla.mozilla.org
General
--
enhancement
RESOLVED WORKSFORME
17 years ago
7 years ago

People

(Reporter: Henrik Gemal, Assigned: Dawn Endico)

Tracking

Details

(Reporter)

Description

17 years ago
If you report a bug with Mozilla the build number of the running Mozilla be 
auto inserted into the description field.

The Description textfield could contain something like this:

"Mozilla build 2001020604 on Windows 2000"

Comment 1

17 years ago
You mean the Bugzilla helper, don't you? This is not part of Webtools/Bugzilla
AFAIK.

Anyway, I just tried it out and the helper does this as far as it can tell:

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20010128
BuildID:    [this is entered by the reporter]

The last two digits are missing, but besides that, the build id is there.
(Although it has to be entered by the reporter again.)

Suggesting works for me.
(Reporter)

Comment 2

17 years ago
Nope, not the helper. I dont use the helper...
insert the text in the description when using:
http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser
Are you proposing we somehow make this a Bugzilla standard feature or that
mozilla.org add a local hack to do this?
(Reporter)

Comment 4

17 years ago
perhaps make it a preference or a javascript button
"Press [Here] to insert your browser name and version"

then it would just append the info to the text area....
Severity: normal → enhancement
Target Milestone: --- → Future

Comment 5

17 years ago
The reporter's build info should be included by default, as this is easily
forgotten and time is often wasted by someone having to ask the reporter which
build they were using and then wait for a reply. (This happened to me just
today, when i forgot to include the build info.)

The enter_bug page is also misleading. It indicates that the build information
fields have already been initialized:

     Some fields initialized from your user-agent, Mozilla/5.0 
     (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010811. 
     If you think it got it wrong, please tell endico@mozilla.org 
     what it should have been.

This suggests to the reporter that the build info can be left out because it
will be inserted automatically. 

Either the build info should be indicated automatically, as suggested by the
reporter of this bug, or the wording of the enter_bug page should be changed to
indicate that the build info will not be inserted automatically.

Comment 6

17 years ago
I think this is mozilla.org specific.
Assignee: tara → endico
Component: Bugzilla → Bugzilla: Other moz.org Issues
Product: Webtools → mozilla.org
QA Contact: matty → myk
*** Bug 116077 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 106499 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
Shouldn't it be a field rather than included in the description?

Updated

15 years ago
Target Milestone: Future → ---
These days, everyone who wouldn't know to include this info uses the guided form
anyway.

Gerv
per comment 10, wfm.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.