Note: There are a few cases of duplicates in user autocompletion which are being worked on.

gmail.com - serves invalid XML to browsers not properly sniffed

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P1
major
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: Andreea Pod, Unassigned)

Tracking

(Blocks: 1 bug)

Details

Attachments

(1 attachment, 1 obsolete attachment)

33.70 KB, image/png
Details
(Reporter)

Description

6 years ago
Created attachment 552326 [details]
XML error

Mozilla /5.0 (Android;Linux armv7l;rv:6.0) Gecko/20110810 Firefox/6.0 Fennec/6.0

Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110810 Firefox/8.0a1 Fennec/8.0a1

Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110810 Firefox/7.0a2 Fennec/7.0a2

Steps to reproduce:
1. go to http://mail.google.com/mail or http://www.gmail.com

Expected result: the log in page should load

Actual result: XML Parsing Error appears, see the screenshot
That seems to me a problem with that site.
But I'm not getting this xml parsing error here, using trunk.

Comment 2

6 years ago
I am also getting this error using trunk. And on the stock browser, gmail.com  is loading fine.
Works for me just fine. Not a Fennec front-end issue.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Resolution: WORKSFORME → INVALID
(Reporter)

Comment 4

6 years ago
Created attachment 553715 [details]
log

This is still reproducing, I attached the log and also please see video: http://www.youtube.com/watch?v=2Ip0xOTZTBU&feature=channel_video_title. 

Mozilla /5.0 (Android;Linux armv7l;rv:7.0) Gecko/20110816 Firefox/7.0 Fennec/7.0
Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110816 Firefox/8.0a1 Fennec/8.0a1

Device: LG Optimus 2X (Android 2.2)
(Reporter)

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Yes, perhaps this can be reproduced, but this is very likely a problem with gmail, not with Fennec.
I've tried to open the Gmail webpage on the stock browser and it has worked fine. I had the same result for a couple of 3rd party browsers. It seems that occurs only for Fennec.
Also I've changed the uagent via Phony add-on and the Gmail webpages has been loaded correctly for all existing options, except the Default one, as you can see here: http://www.youtube.com/user/qaioana#p/a/u/0/8cP_qY0nezg
I hope that this view-source code it would be helpful: http://pastebin.mozilla.org/1302511
Version: Firefox 8 → Trunk
It's happening because the ampersand in this link isn't escaped:
<a href="http://mail.google.com/mail/signup?pc=mobile&ep=go_mobile%3D1%26btmpl%3Dmobile_tier2%26idvToken%3D">

So this is a tech evangelism issue.

I wasn't seeing this issue, because I don't see the "New to Gmail? It's free and easy" part. I guess Google knows that I'm already using gmail.
Assignee: nobody → english-us
Component: General → English US
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified
In Error Console the following error occurs:

Error: not well-formed
https://www.google.com/accounts/ServiceLogin?service=mail&passive=true&continue=http%3A%2F%2Fmail.google.com%2Fmail%2F%3Fui%3Dmobile%26zyp%3Dl&bsv=llya694le36z&scc=1&ltmpl=ecobx&nui=5&btmpl=mobile&from=login
76
  <b><a href="http://mail.google.com/mail/signup?pc=mobile&ep=go_mobile%3D1%26btmpl%3Dmobile_tier2%26idvToken%3D">Create an account now</a></b>
62

Updated

6 years ago
Blocks: 668288
Raising severity seeing that Mobile Firefox users can't see nor login to Gmail which is extremely bad.
Severity: normal → major
Priority: -- → P1

Updated

6 years ago
Summary: XML Parsing Error: not well-formed on gmail.com → XML Parsing Error: not well-formed on gmail.com (Mobile Firefox)
Input: http://input.mozilla.com/en-US/opinion/2289383
http://input.mozilla.com/en-US/opinion/2323793
http://input.mozilla.com/en-US/opinion/2346228
http://input.mozilla.com/en-US/opinion/2346323
http://input.mozilla.com/en-US/opinion/2348009

Updated

6 years ago
Attachment #553715 - Attachment is obsolete: true
http://input.mozilla.com/en-US/opinion/2353183
http://input.mozilla.com/en-US/opinion/2355305

Updated

6 years ago
Status: REOPENED → NEW
Yeesh, http://input.mozilla.com/en-US/?q=gmail+xml&product=mobile&version=--&date_start=&date_end=
FWIW, this is definitely because GMail serves another content to Firefox (and Opera). Changing the user agent to the stock Android browser solves the issue. That's really sad...

Comment 17

6 years ago
So not only are they browser-sniffing, but they're serving invalid XML to browsers they don't recognize. Lovely.
Summary: XML Parsing Error: not well-formed on gmail.com (Mobile Firefox) → gmail.com - serves invalid XML to browsers not properly sniffed
http://input.mozilla.com/en-US/opinion/2360431
http://input.mozilla.com/en-US/opinion/2359726

What will it take for this bug to get looked at and assigned a contact to speak to Google?

Comment 19

6 years ago
Opera has the same type of issues with a few sites, specifically ASP.
http://my.opera.com/ODIN/blog/2011/08/12/asp-wrong-mime-type

Basically the sensible thing to do is to reparse the page as HTML (common users) and send a warning or error in the log (web developers).
Paul, by any chance, could you point this bug to whom can fix it?
(In reply to Aaron Train [:aaronmt] from comment #18)

> What will it take for this bug to get looked at and assigned a contact to
> speak to Google?

You are assuming that we have not poked Google about this?

Comment 22

6 years ago
(In reply to Karl Dubost from comment #19)

> Basically the sensible thing to do is to reparse the page as HTML (common
> users) and send a warning or error in the log (web developers).

Someone should probably file a new bug against Gecko to do exactly that, since throwing up a "this site is broken" page is poor UE compared to "this site is broken, but we'll show it to you anyway".

Comment 23

6 years ago
It seems that many more mobile browsers are having the same problem with Gmail since august 30:
http://www.google.com/support/forum/p/Google+Mobile/thread?tid=08970ac274f70421&hl=en
I just attempted to login today and this seems fixed; was able to login, compose and read email. Can someone else verify that all is fixed now?
Yeah, seems fixed. I'm able to login too.
Status: NEW → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Updated

5 years ago
No longer blocks: 668288

Updated

5 years ago
Blocks: 668288
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.