Last Comment Bug 678150 - gmail.com - serves invalid XML to browsers not properly sniffed
: gmail.com - serves invalid XML to browsers not properly sniffed
Status: RESOLVED FIXED
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: ARM Android
: P1 major
: ---
Assigned To: english-us
:
Mentors:
Depends on:
Blocks: google-evangelism
  Show dependency treegraph
 
Reported: 2011-08-11 02:03 PDT by Andreea Pod
Modified: 2015-04-19 23:39 PDT (History)
21 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
XML error (33.70 KB, image/png)
2011-08-11 02:03 PDT, Andreea Pod
no flags Details
log (20.55 KB, text/plain)
2011-08-17 02:31 PDT, Andreea Pod
no flags Details

Description Andreea Pod 2011-08-11 02:03:25 PDT
Created attachment 552326 [details]
XML error

Mozilla /5.0 (Android;Linux armv7l;rv:6.0) Gecko/20110810 Firefox/6.0 Fennec/6.0

Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110810 Firefox/8.0a1 Fennec/8.0a1

Mozilla /5.0 (Android;Linux armv7l;rv:7.0a2) Gecko/20110810 Firefox/7.0a2 Fennec/7.0a2

Steps to reproduce:
1. go to http://mail.google.com/mail or http://www.gmail.com

Expected result: the log in page should load

Actual result: XML Parsing Error appears, see the screenshot
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-08-11 02:49:31 PDT
That seems to me a problem with that site.
But I'm not getting this xml parsing error here, using trunk.
Comment 2 Anna (Waverley) 2011-08-11 03:30:34 PDT
I am also getting this error using trunk. And on the stock browser, gmail.com  is loading fine.
Comment 3 Aaron Train [:aaronmt] 2011-08-11 06:03:11 PDT
Works for me just fine. Not a Fennec front-end issue.
Comment 4 Andreea Pod 2011-08-17 02:31:54 PDT
Created attachment 553715 [details]
log

This is still reproducing, I attached the log and also please see video: http://www.youtube.com/watch?v=2Ip0xOTZTBU&feature=channel_video_title. 

Mozilla /5.0 (Android;Linux armv7l;rv:7.0) Gecko/20110816 Firefox/7.0 Fennec/7.0
Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110816 Firefox/8.0a1 Fennec/8.0a1

Device: LG Optimus 2X (Android 2.2)
Comment 5 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-08-17 02:33:53 PDT
Yes, perhaps this can be reproduced, but this is very likely a problem with gmail, not with Fennec.
Comment 6 Cristian Nicolae (:xti) 2011-08-17 04:44:24 PDT
I've tried to open the Gmail webpage on the stock browser and it has worked fine. I had the same result for a couple of 3rd party browsers. It seems that occurs only for Fennec.
Also I've changed the uagent via Phony add-on and the Gmail webpages has been loaded correctly for all existing options, except the Default one, as you can see here: http://www.youtube.com/user/qaioana#p/a/u/0/8cP_qY0nezg
I hope that this view-source code it would be helpful: http://pastebin.mozilla.org/1302511
Comment 7 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-08-17 04:50:24 PDT
It's happening because the ampersand in this link isn't escaped:
<a href="http://mail.google.com/mail/signup?pc=mobile&ep=go_mobile%3D1%26btmpl%3Dmobile_tier2%26idvToken%3D">

So this is a tech evangelism issue.

I wasn't seeing this issue, because I don't see the "New to Gmail? It's free and easy" part. I guess Google knows that I'm already using gmail.
Comment 9 Aaron Train [:aaronmt] 2011-08-17 06:52:09 PDT
Raising severity seeing that Mobile Firefox users can't see nor login to Gmail which is extremely bad.
Comment 10 Aaron Train [:aaronmt] 2011-08-17 09:55:51 PDT
Input: http://input.mozilla.com/en-US/opinion/2289383
Comment 11 Aaron Train [:aaronmt] 2011-08-31 10:43:12 PDT
http://input.mozilla.com/en-US/opinion/2323793
Comment 13 Aaron Train [:aaronmt] 2011-09-02 14:21:03 PDT
http://input.mozilla.com/en-US/opinion/2348009
Comment 16 Mounir Lamouri (:mounir) 2011-09-09 05:16:24 PDT
FWIW, this is definitely because GMail serves another content to Firefox (and Opera). Changing the user agent to the stock Android browser solves the issue. That's really sad...
Comment 17 Chris Lawson (gone) 2011-09-09 05:26:35 PDT
So not only are they browser-sniffing, but they're serving invalid XML to browsers they don't recognize. Lovely.
Comment 18 Aaron Train [:aaronmt] 2011-09-09 06:12:00 PDT
http://input.mozilla.com/en-US/opinion/2360431
http://input.mozilla.com/en-US/opinion/2359726

What will it take for this bug to get looked at and assigned a contact to speak to Google?
Comment 19 Karl Dubost 2011-09-09 06:20:09 PDT
Opera has the same type of issues with a few sites, specifically ASP.
http://my.opera.com/ODIN/blog/2011/08/12/asp-wrong-mime-type

Basically the sensible thing to do is to reparse the page as HTML (common users) and send a warning or error in the log (web developers).
Comment 20 Mounir Lamouri (:mounir) 2011-09-09 06:23:10 PDT
Paul, by any chance, could you point this bug to whom can fix it?
Comment 21 Mark Finkle (:mfinkle) (use needinfo?) 2011-09-09 06:35:06 PDT
(In reply to Aaron Train [:aaronmt] from comment #18)

> What will it take for this bug to get looked at and assigned a contact to
> speak to Google?

You are assuming that we have not poked Google about this?
Comment 22 Chris Lawson (gone) 2011-09-09 08:02:15 PDT
(In reply to Karl Dubost from comment #19)

> Basically the sensible thing to do is to reparse the page as HTML (common
> users) and send a warning or error in the log (web developers).

Someone should probably file a new bug against Gecko to do exactly that, since throwing up a "this site is broken" page is poor UE compared to "this site is broken, but we'll show it to you anyway".
Comment 23 Peter 2011-09-12 12:01:36 PDT
It seems that many more mobile browsers are having the same problem with Gmail since august 30:
http://www.google.com/support/forum/p/Google+Mobile/thread?tid=08970ac274f70421&hl=en
Comment 24 Aaron Train [:aaronmt] 2011-09-15 09:50:53 PDT
I just attempted to login today and this seems fixed; was able to login, compose and read email. Can someone else verify that all is fixed now?
Comment 25 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-09-15 10:01:42 PDT
Yeah, seems fixed. I'm able to login too.

Note You need to log in before you can comment on or make changes to this bug.