apostrophe doesn't work in forum search with http

RESOLVED WORKSFORME

Status

support.mozilla.org
Questions
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: atopal, Unassigned)

Tracking

unspecified
2011Q3
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Form http://support.mozilla.com/en-US/questions I tried the search term "icons won't stick" and it escaped the apostrophe, searching for "icons won%27t stick" which of course leads to no results.


Also, for some reason, when I'm logged in and using https the listing here
https://support.mozilla.com/en-US/questions looks different from the not logged in http version. And I'm not sure why that is. Are we using different filter for logged in users? And if yes, which ones do we use?
I can't reproduce either of these issues. (Please file separate bugs for separate issues :)

(In reply to Kadir Topal [:atopal] from comment #0)
> Form http://support.mozilla.com/en-US/questions I tried the search term
> "icons won't stick" and it escaped the apostrophe, searching for "icons
> won%27t stick" which of course leads to no results.

It escapes in the URL--it has to--but in the search box on the results page I see "icons won't stick" and several results.

Did you copy and paste the string out of the location bar at some point? The location bar lies a little bit, showing nice, unescaped strings, but if you select and copy, it gives you the "real" version, which would be URL encoded.


> Also, for some reason, when I'm logged in and using https the listing here
> https://support.mozilla.com/en-US/questions looks different from the not
> logged in http version. And I'm not sure why that is. Are we using different
> filter for logged in users? And if yes, which ones do we use?

No, but we always send "never cache" headers on HTTPS requests, so Zeus does no caching there. On HTTP, I believe we let Zeus cache /questions for 15 minutes (I'm not sure about the time, it could be longer) so it may show slightly different content for a while until the Zeus cache expires.
(Reporter)

Comment 2

6 years ago
(In reply to James Socol [:jsocol, :james] from comment #1)
> I can't reproduce either of these issues. (Please file separate bugs for
> separate issues :)
> 
> (In reply to Kadir Topal [:atopal] from comment #0)
> > Form http://support.mozilla.com/en-US/questions I tried the search term
> > "icons won't stick" and it escaped the apostrophe, searching for "icons
> > won%27t stick" which of course leads to no results.
> 
> It escapes in the URL--it has to--but in the search box on the results page
> I see "icons won't stick" and several results.
> 
> Did you copy and paste the string out of the location bar at some point? The
> location bar lies a little bit, showing nice, unescaped strings, but if you
> select and copy, it gives you the "real" version, which would be URL encoded.

I tried it several times and actually typed it out, always with the same result. But now it just works :/ I'll WFM this.

 
> > Also, for some reason, when I'm logged in and using https the listing here
> > https://support.mozilla.com/en-US/questions looks different from the not
> > logged in http version. And I'm not sure why that is. Are we using different
> > filter for logged in users? And if yes, which ones do we use?
> 
> No, but we always send "never cache" headers on HTTPS requests, so Zeus does
> no caching there. On HTTP, I believe we let Zeus cache /questions for 15
> minutes (I'm not sure about the time, it could be longer) so it may show
> slightly different content for a while until the Zeus cache expires.

Oh, okay, that might be it. I didn't look back in the history too much, just saw that the first few questions in the list were different.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.