[adbe 2982873] Plugin and Content Flash Crash [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ npswf32.dll@0x39c2b3 ] [@ FlashPlayer-10.4-10.5@0x61bfd2 ]

VERIFIED FIXED

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: bc, Assigned: smadayag)

Tracking

(Blocks: 1 bug, {crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

Created attachment 552459 [details]
mac stack aurora

0. Flash 10.3.183.5
1. http://static.issuu.com/webembed/viewers/style1/v1/1/0/Viewer-1158.swf
2. Maybe need to reload
3. Crash content+plugin process Beta/6, Aurora/7, Nightly/8 Mac, Windows

bp-b4ec8cb2-ad82-46b4-b1c2-46fa22110811

0 	FlashPlayer-10.4-10.5 	F1949931376__________________ 	
1 	FlashPlayer-10.4-10.5 	F_1548056655________________________________ 	
2 	FlashPlayer-10.4-10.5 	F1833736136__________________________ 	
3 	FlashPlayer-10.4-10.5 	F1955646647_______ 	
4 	FlashPlayer-10.4-10.5 	F_34356807_______ 	
5 	FlashPlayer-10.4-10.5 	F1704956168____________ 	
6 	FlashPlayer-10.4-10.5 	F_656797__________ 	
7 	FlashPlayer-10.4-10.5 	F_1368878015___ 	
8 	FlashPlayer-10.4-10.5 	F_1337695921_ 	
9 	FlashPlayer-10.4-10.5 	F_551017250______________ 	
10 	FlashPlayer-10.4-10.5 	F2130261894______________________ 	
11 	FlashPlayer-10.4-10.5 	F1807888270____________________ 	
12 	FlashPlayer-10.4-10.5 	F357724114_____________________ 	
13 	FlashPlayer-10.4-10.5 	F50850_____ 	
14 	XUL 	nsNPAPIPluginInstance::Stop

bp-dc6be1bf-3178-468d-b8e1-a00482110811

Originally found from http://www.gn-online.de/de/lokales/nordhorn.html?artikelid=403187%26n=CDU%2520setzt%2520auf%2520Sieg%2520und%2520will%2520st%25C3%25A4rkste%2520Ratsfraktion%2520werden which is associated with the Socorro Signature nsPluginInstanceOwner::ReleasePluginPort(void*)

See bug 562442

Still investigating the url for more issues.
Crash Signature: [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ]
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Summary: Plugin and Content Flash Crash [@ F1949931376__________________] [@ F_363836192______________________________ ] [@ NP_Initialize ] → Plugin and Content Flash Crash [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ]
Version: Trunk → 10.3
Still exists in Flash 10.3.183.10 Sal, Werner: what is the status here?
Crash Signature: [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] → [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ NPSWF32.dll@0x39c2b3 ]
Crash Signature: [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ NPSWF32.dll@0x39c2b3 ] → [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ NPSWF32.dll@0x39c2b3 ] [@ FlashPlayer-10.4-10.5@0x61bfd2 ]
(Assignee)

Comment 2

7 years ago
the signature is lower in priority and not been assigned at this time.  there are no reports in windows and currently ranks #28 on Mac OS X.  should we raise priority on this one?  please let us know, i'll adjust our internal bug if needed.
comments from our users (available publicly via crash-stats.mozilla.com)

F1949931376__________________ 

普通にクリックしたらいきなり消えた。 (Suddenly disappears when you click as usual.)

Version 3.6.21 crashed on me a few times. I am using OS X 10.4.11.

This is getting annoying!!!!!!!!

STILL with the Social City!!!!!!!!!!!!!

Okay every time I get to moodle and click all course Firefox just stops!!!! Grrrrr

It just suddenly crashed. Everything was normal but then it got the loading pinwheel thing, and crashee

It just stopped while I was accessing moodle 

I was closing extra tabs, and waiting for a Facebook game to load

i run OSX 10.4.11 on my old iMac, and yes, Firefox crashed often during my work session lately

Hey guys, yeah this is coming to maybe the 10th time now that this has happened, its more of an annoyance than anything. Essentially, when heading on over to youtube, firefox crashes. 

firefox closes unexpectidly

Every time I go to the Social City App on FB, Firefox crashes! Every single time!! What's up?

crashed when waiting for a page to load...

complete crash for no reason

AGAIN! What is it about Social City on FB that Firefox doesn't like?!

Absturz nur bei : http://ecosia.org/search.php?addon=firefox&q=boulevard+baden
...

It appears Social City is a facebook game <https://www.facebook.com/SocialCity> with 752,973 monthly average users which mean this is possible a bigger issue for Mac users and not just one user complaining about Social City.

If moodle is https://secure.wikimedia.org/wikipedia/en/wiki/Moodle , then it has "55,110 registered sites with 44,966,541 users in 4,763,446 courses in 214 countries and in more than 75 languages"

Please have the crash diagnosed with respect to difficulty to patch. If this is easy to fix or pave over, then it would certainly help our users who are specifically impacted.
(Assignee)

Comment 4

7 years ago
i was unable to reproduce with the original URLs.  i'll revisit the comments and retry...
I just loaded http://static.issuu.com/webembed/viewers/style1/v1/1/0/Viewer-1158.swf into Windows XP Nightly debug build, clicked reload once and crashed at NPSWF32.dll@0481c2b3(). I did the same with a Nightly nightly build and also crashed. The crash report is at bp-e66b18f7-bd20-497c-8a82-0f2e82110923

I did the same with a Mac OS X 10.5 Nightly debug build and crashed [@ NP_Initialize ]. Using an Aurora nightly build on Mac OS X 10.5 crashed with bp-5a257ab6-3cde-490a-a946-f8f6e2110923 [@ FlashPlayer-10.4-10.5@0x61bfd2].

If you don't crash immediately, reload it.
Crash Signature: [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ NPSWF32.dll@0x39c2b3 ] [@ FlashPlayer-10.4-10.5@0x61bfd2 ] → [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ NPSWF32.dll@0x39c2b3 ] [@ FlashPlayer-10.4-10.5@0x61bfd2 ] [@ npswf32.dll@0x39c2b3 ]
Summary: Plugin and Content Flash Crash [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] → Plugin and Content Flash Crash [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ npswf32.dll@0x39c2b3 ] [@ FlashPlayer-10.4-10.5@0x61bfd2 ]
(In reply to Bob Clary [:bc:] from comment #5)
> Using an Aurora nightly build on Mac OS X 10.5 crashed with
...

Mac that Beta (soon to be Firefox 7). Here is Aurora's bp-0efc79f6-cc37-4333-9968-bacf62110923 [@ FlashPlayer-10.4-10.5@0x61bfd2 ] and here is Firefox 6.0.2's bp-7af6ef28-dfc9-47fa-b6ca-4e3f72110923 [@ FlashPlayer-10.4-10.5@0x61bfd2 ]
(Assignee)

Comment 7

7 years ago
our internal bug, #2982873, has been assigned to the next open release, Anza.  thanks...
Assignee: nobody → smadayag
Status: NEW → ASSIGNED
Summary: Plugin and Content Flash Crash [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ npswf32.dll@0x39c2b3 ] [@ FlashPlayer-10.4-10.5@0x61bfd2 ] → [adbe 2982873] Plugin and Content Flash Crash [@ F1949931376__________________ ] [@ F_363836192______________________________ ] [@ NP_Initialize ] [@ npswf32.dll@0x39c2b3 ] [@ FlashPlayer-10.4-10.5@0x61bfd2 ]
(Assignee)

Comment 8

7 years ago
code change made it into our Serrano release, 11,0,1,152.  closing fixed...
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Sal, thanks! Will this make it into 10.3.183.x ? That is still the latest version available for Mac OS X 10.5.
(Assignee)

Comment 10

7 years ago
you are correct, fp11 isn't available on 10.5.  let me clone our internal bug and see if there is a backport option.  how would you like to treat this bug as the issue also reproduced on OSX 10.6, Windows and not just OSX 10.4-10.5?
Confirm this is fixed on Mac OS X 10.6, Linux, Windows XP, Windows 7 with Flash 11,0,1,152.

Sal, I think this should stay fixed as your latest version includes it. Anyone who runs across the crash and investigates will find this bug and at least understand the situation (hopefully). Keep us informed as to whether 10.3.183 will be fixed. Thanks again!
Status: RESOLVED → VERIFIED

Comment 12

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 10.3 → unspecified
You need to log in before you can comment on or make changes to this bug.