pressing return key after inserting <hr> doesn't show <br>

VERIFIED DUPLICATE of bug 159207

Status

()

Core
Editor
P2
normal
VERIFIED DUPLICATE of bug 159207
16 years ago
15 years ago

People

(Reporter: bijals (gone), Assigned: Joe Francis)

Tracking

({embed})

Trunk
mozilla1.2beta
embed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [behavior] EDITORBASE-; 1 day [adt3])

(Reporter)

Description

16 years ago
Steps:
1) Open a blank document in Composer
2) Hit return
3) Click the horizontal line button on tool bar
Caret is on line below horizontal line in most cases
4) Hit return
Caret does not move to the next line
5) Hit return
6) Move caret up 2 rows using arrow keys
7) Move caret down to last line created
Caret will not go 2 lines below horizontal line

Actual Results: 2 problems.  Caret does not create a new line on first return 
click.  Also, caret does not move to all rows using arrow keys.

Build Date/Platform: 2001020504 using N

Comment 1

16 years ago
confirmed...I see this also as described...

Comment 2

16 years ago
assigning to jfrancis, setting to moz0.9.1
Assignee: beppe → jfrancis
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 3

16 years ago
beppe, we will have to eventually split this out as two bugs.  problems when
hitting return should indeed go to me, but the arrow key issue is seperate and
should go to selection owner d'jour.
Status: NEW → ASSIGNED
Priority: -- → P3

Comment 4

16 years ago
This bug (or a part of it) is probably a dup of bug 55031.
Summary: Can't move caret up and down → Can't move caret up and down (<hr> involved)

Comment 5

16 years ago
correcting summary; adjusting platforms (I see this bug on Mac)

There seems to be some kind of rendering issue.  If you do the first 4 steps 
listed and then save and preview the document in the browser, you'll see a 
different spacing.  Also, if you close and reopen the saved document in Composer.

As Jesse says, the caret movement issues are covered in #55031.
OS: Windows NT → All
Hardware: PC → All
Summary: Can't move caret up and down (<hr> involved) → pressing return key after inserting <hr> doesn't show <br>
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

16 years ago
Keywords: correctness
Whiteboard: [behavior]
Target Milestone: mozilla0.9.2 → mozilla1.0
(Assignee)

Updated

16 years ago
Whiteboard: [behavior] → [behavior] EDITORBASE; 1 day

Comment 6

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 7

16 years ago
Issue still presnt in mac os x build 2001121805.

Comment 8

16 years ago
triage is plussing
Whiteboard: [behavior] EDITORBASE; 1 day → [behavior] EDITORBASE+; 1 day

Updated

15 years ago
Keywords: nsbeta1+

Updated

15 years ago
Keywords: topembed
Bulk moving all nsbeta1+ bugs which were targetted after Mozilla1.0 to Mozilla1.0
Target Milestone: mozilla1.0.1 → mozilla1.0

Updated

15 years ago
Keywords: topembed → topembed+
(Assignee)

Comment 10

15 years ago
pri = 2 for original 1.0 EB+ bugs
Priority: P3 → P2

Comment 11

15 years ago
adt3 per adt triage
Whiteboard: [behavior] EDITORBASE+; 1 day → [behavior] EDITORBASE+; 1 day [adt3]

Updated

15 years ago
Keywords: nsbeta1+ → nsbeta1-
Whiteboard: [behavior] EDITORBASE+; 1 day [adt3] → [behavior] EDITORBASE-; 1 day [adt3]
Target Milestone: mozilla1.0 → mozilla1.1alpha

Updated

15 years ago
Keywords: topembed+ → embed
(Assignee)

Comment 12

15 years ago
The trunk is the wave of the future!
Target Milestone: mozilla1.1alpha → mozilla1.1beta
(Assignee)

Comment 13

15 years ago
The days of having a half dozen milestones out in front of us to divide bugs 
between seem to be gone, though I dont know why.  Lumping everything together as 
far out as I can.  I'll pull back things that I am working on as I go.
Target Milestone: mozilla1.1beta → mozilla1.2beta

Comment 14

15 years ago
I cannot reproduce either of the described problems.
The caret problems around HRs were fixed by mjudge in bug 159207.


*** This bug has been marked as a duplicate of 159207 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Keywords: nsbeta1- → nsbeta1
Resolution: --- → DUPLICATE

Comment 15

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.