Closed Bug 678431 Opened 8 years ago Closed 8 years ago

Compilation without MOZ_MEDIA defined is broken

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla8

People

(Reporter: romaxa, Assigned: romaxa)

Details

Attachments

(1 file, 2 obsolete files)

Fix compilation without MOZ_MEDIA.
Attached patch Fix build without MOZ_MEDIA (obsolete) — Splinter Review
Assignee: nobody → romaxa
Status: NEW → ASSIGNED
Attachment #552582 - Flags: review?(Olli.Pettay)
Comment on attachment 552582 [details] [diff] [review]
Fix build without MOZ_MEDIA

We don't want to do it this way, since this will break once
onfoo properties are added to the idl.

If the problem is the nsGkAtoms, remove some ifdefs there.
Attachment #552582 - Flags: review?(Olli.Pettay) → review-
Is there actually an interest in keeping MOZ_MEDIA disable-able?
not so much... I'm just building it for WebOS environment... and trying to get first basics working (at mean time disabling some more complicated features)... disable configs are available but not  working... so I guess it would be nice to or remove that at all, or keep it working if people sending patches.
Attachment #552839 - Flags: review?
Attachment #552839 - Flags: review? → review?(Olli.Pettay)
Attachment #552582 - Attachment is obsolete: true
Oh, forgot another part
Attachment #552839 - Attachment is obsolete: true
Attachment #552839 - Flags: review?(Olli.Pettay)
Attachment #552840 - Flags: review?(Olli.Pettay)
Attachment #552840 - Flags: review?(Olli.Pettay) → review+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/3ab9371af845
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.