Last Comment Bug 678519 - GCLI needs to distinguish between sufficient completions and insufficient ones
: GCLI needs to distinguish between sufficient completions and insufficient ones
Status: RESOLVED FIXED
[minotaur][best:1d, likely:1d, worst:1d]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks: GCLI-JS
  Show dependency treegraph
 
Reported: 2011-08-12 09:00 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2011-08-16 10:12 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-08-12 09:00:30 PDT
For example:
> hel<TAB>

Should complete to:
> help_|

(i.e. there needs to be a space added as part of the completion because:
- That saves keypresses
- It's what zsh/bash etc do
- otherwise the cursor is inside the 'command' and we provide help for the command rather than what's next

However:
> eval window.docu<TAB>

Using the same logic we should complete to:
> eval window.document_|

However this is really annoying because it's likely that the user want's to continue typing, digging into document.
We need to support this way of doing things because:
- this is what Firebug/webkit inspector etc do.
- completing too much is really annoying


To further complicate things:
> eval window.document.titl<TAB>

Clearly in this case we need the space added.

Note You need to log in before you can comment on or make changes to this bug.