Closed Bug 678552 Opened 8 years ago Closed 7 years ago

Intermittent mochitest, mochitest-browser-chrome, mochitest-a11y leak of 172/184 bytes (1 Mutex, 1 ReentrantMonitor, 1/2 nsRunnable, 1 nsTArray_base, 1 nsThread)

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mbrubeck, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, intermittent-failure, memory-leak)

http://tbpl.mozilla.org/leak-analysis/?id=1313091090.1313095623.20415.gz&tree=Firefox says "chrome://mochitests/content/chrome/dom/ipc/tests/test_process_error.xul leaked 1 DOMWINDOW(s)" but I believe it is generally known to be irrelevant when the leak analyzer blames that file.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1313091090.1313095623.20415.gz
Rev3 WINNT 5.1 mozilla-central debug test mochitest-other on 2011/08/11 12:31:30 

SUCCESS: The process with PID 1660 has been terminated.

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, default process 3188

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          17      172 495282985        5 ( 5276.55 +/- 11878.58) 375930255        2 (10749.21 +/- 23266.55)
 152 Mutex                                          12       12    20351        1 (  123.84 +/-    12.97)        0        0 (    0.00 +/-     0.00)
 191 ReentrantMonitor                               16       16    12383        1 (   77.22 +/-    17.42)        0        0 (    0.00 +/-     0.00)
 954 nsRunnable                                     12       12   593355        1 (   26.89 +/-    45.15)  1841621        1 (   31.93 +/-    48.26)
1092 nsTArray_base                                   4        4 23824088        1 (51848.83 +/- 17924.00)        0        0 (    0.00 +/-     0.00)
1103 nsThread                                      128      128      242        1 (   20.30 +/-     6.06)   359886        1 (  150.59 +/-    35.98)

nsTraceRefcntImpl::DumpStatistics: 1266 entries
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 172 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of Mutex with size 12 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of ReentrantMonitor with size 16 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of nsRunnable with size 12 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of nsTArray_base with size 4 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of nsThread with size 128 bytes

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, plugin process 184

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          13        0      824        0 (   29.35 +/-    23.99)      478        0 (   77.26 +/-    51.47)

nsTraceRefcntImpl::DumpStatistics: 20 entries
TEST-PASS | plugin process 184 | automationutils.processLeakLog() | no leaks detected!

INFO | runtests.py | Running tests: end.
Not sure how many other suites we've ignored it in, but at least mochitest-a11y since I've got one right here.

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313167419.1313171746.16183.gz&fulltext=1#err0
Rev3 WINNT 5.1 mozilla-inbound debug test mochitest-other on 2011/08/12 09:43:39
s: talos-r3-xp-039

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313184803.1313189438.412.gz&fulltext=1#err2
Rev3 WINNT 6.1 mozilla-inbound debug test mochitest-other on 2011/08/12 14:33:23
s: talos-r3-w7-017
Summary: Intermittent mochitest-browser-chrome leak of 172 bytes (1 Mutex, 1 ReentrantMonitor, 1 nsRunnable, 1 nsTArray_base, 1 nsThread) → Intermittent mochitest-browser-chrome, mochitest-a11y leak of 172 bytes (1 Mutex, 1 ReentrantMonitor, 1 nsRunnable, 1 nsTArray_base, 1 nsThread)
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313187703.1313191522.8407.gz
Rev3 Fedora 12 mozilla-inbound debug test mochitest-other on 2011/08/12 15:21:43
s: talos-r3-fed-008
OS: Windows XP → All
Hardware: x86 → All
Version: 8 Branch → Trunk
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1313286241.1313288157.9691.gz
Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-1/5 on 2011/08/13 18:44:01
Summary: Intermittent mochitest-browser-chrome, mochitest-a11y leak of 172 bytes (1 Mutex, 1 ReentrantMonitor, 1 nsRunnable, 1 nsTArray_base, 1 nsThread) → Intermittent mochitest, mochitest-browser-chrome, mochitest-a11y leak of 172 bytes (1 Mutex, 1 ReentrantMonitor, 1 nsRunnable, 1 nsTArray_base, 1 nsThread)
Now with two runnables:

http://tbpl.allizom.org/php/getParsedLog.php?id=5984540
Summary: Intermittent mochitest, mochitest-browser-chrome, mochitest-a11y leak of 172 bytes (1 Mutex, 1 ReentrantMonitor, 1 nsRunnable, 1 nsTArray_base, 1 nsThread) → Intermittent mochitest, mochitest-browser-chrome, mochitest-a11y leak of 172/184 bytes (1 Mutex, 1 ReentrantMonitor, 1/2 nsRunnable, 1 nsTArray_base, 1 nsThread)
Despite a bit of excess, I'm still calling http://tbpl.allizom.org/php/getParsedLog.php?id=5993855 this until proven wrong, despite the overachieving

TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 3904 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 10 instances of Mutex with size 12 bytes each (120 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of ReentrantMonitor with size 16 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 9 instances of nsStringBuffer with size 8 bytes each (72 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 10 instances of nsTArray_base with size 4 bytes each (40 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of nsThread with size 128 bytes
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of nsTimerImpl with size 72 bytes each (648 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of nsVoidArray with size 4 bytes each (36 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of nsWebShellWindow with size 168 bytes each (1512 bytes total)
TEST-INFO | automationutils.processLeakLog() | leaked 9 instances of nsXULWindow with size 148 bytes each (1332 bytes total)
http://tbpl.allizom.org/php/getParsedLog.php?id=6108614 (which is interesting, since it was on IonMonkey on the 24th, and IM probably hasn't had a merge from m-c since the 17th, when this apparently got fixed, or the cause got coincidentally backed out)
http://tbpl.allizom.org/php/getParsedLog.php?id=6152653 on the other hand, is on Jaegermonkey two pushes after a merge from m-c as of the morning of the 26th.
And http://tbpl.allizom.org/php/getParsedLog.php?id=6181149 is off the tip of m-c, so never mind me.
Keywords: access
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.