selfserve agent shouldn't wait forever trying to cancel a build

RESOLVED INCOMPLETE

Status

P4
normal
RESOLVED INCOMPLETE
7 years ago
5 years ago

People

(Reporter: mdas, Unassigned)

Tracking

({buildapi})

Firefox Tracking Flags

(Not tracked)

Details

I'm watching a build of revision 76505e286fbac352319710ec40f7a9ec22ab461a on mozilla-central. I requested a rebuild of both "Android Tegra 250 mozilla-central opt test mochitest-7" and "Android Tegra 250 mozilla-central talos remote-tzoom" a few hours ago, but I still don't see the rebuilds showing up in self-serve. I hit the Rebuild button in both the self-serve API UI and by hitting the '+' button on the main tbpl page. When I hit rebuild in self-serve, I got a confirmation, but the request did not show up in the pending builds.

Please let me know if any further information is required.
If hitting the rebuild button in self-serve didn't work, than that's a self-serve problem.
Component: Tinderboxpushlog → Release Engineering
Product: Webtools → mozilla.org
QA Contact: tinderboxpushlog → release
Version: Trunk → other
so our selfserve agent bot got wedged waiting on a dropped tcp connection. I've cleared that up now.

morphing this bug to add a timeout in selfserve-agent so we don't hit this again.
Assignee: nobody → catlee
Summary: Rebuild request doesn't seem to be honored → selfserve agent shouldn't wait forever trying to cancel a build
Whiteboard: [self-serve]
Assignee: catlee → nobody
OS: Mac OS X → All
Priority: -- → P4
Hardware: x86 → All
Keywords: buildapi
Whiteboard: [self-serve]
Product: mozilla.org → Release Engineering
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.