All users were logged out of Bugzilla on October 13th, 2018

Deadlock after adding cert override

RESOLVED DUPLICATE of bug 678440

Status

()

RESOLVED DUPLICATE of bug 678440
7 years ago
7 years ago

People

(Reporter: kaie, Assigned: luke)

Tracking

({hang, qawanted, regression})

Trunk
x86
Linux
hang, qawanted, regression
Points:
---

Firefox Tracking Flags

(firefox8 affected)

Details

(Reporter)

Description

7 years ago
- fresh profile
- go to https://www.cacert.org
- "I understant the risks"
- add exception, confirm

The dialog closes.
The browser attempts to reload the page.

It stalls forever.
I can use "stop", I can enter another URL into the location bar, but it fails to load.

Note that after a restart of the application the page loads fine.
I believe this regression was caused by bug 674571.
(Reporter)

Updated

7 years ago
Assignee: nobody → luke
status-firefox8: --- → affected
tracking-firefox8: --- → ?
(Assignee)

Comment 1

7 years ago
I tried several times to reproduce on OSX with a nightly and no luck.  Is it every time for you?  Also, as the patches were just the "obvious" translation from (previously unsafe) proxies, I would appreciate any advice you have on this patch since you certainly understand what's actually going on in the code much better than I do.
Blocks: 674571
No longer depends on: 674571
(Reporter)

Comment 2

7 years ago
Maybe it's Linux specific?
Happened to me with my own debug build.

If I backout your patch, I crash with the expected assertion (GetProxyForObject on wrapped JS not allowed).

I apply your patch, and I get your deadlock.


Could someone else running Linux please try to reproduce?
OS: All → Linux
Hardware: All → x86
(Reporter)

Comment 3

7 years ago
I am no longer able to reproduce myself.
Sorry for the noise :(

Maybe it was the side effect of another patch I had in my tree.
I'll reopen if it reoccurs.
No longer blocks: 674571
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

7 years ago
Well, I don't know yet.
I tried the other potential culprit (my own work-in-progress-patch),
but I still cannot reproduce.

Maybe there is a random component to reproducing this bug.

I propose, let's try to find someone running Linux, who is able to reproduce this bug.

I'm changing to UNCONFIRMED and asking for QAWANTED.
Severity: blocker → normal
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Keywords: qawanted
Resolution: INVALID → ---
Luke, try unchecking the "Permanently store this exception" checkbox in the exception window, when trying to reproduce. If you get a crash instead, see bug 678710.
Mozilla/5.0 (X11; Linux i686; rv:9.0a1) Gecko/20110818 Firefox/9.0a1

Attempted to reproduce this issue several times using the steps in the description on the latest nightly. Worked fine for me.
(Assignee)

Comment 7

7 years ago
This reflects the backout for the 8/18 nightly:
http://hg.mozilla.org/mozilla-central/rev/5f0596a0b81e
(Assignee)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 678440

Updated

7 years ago
tracking-firefox8: ? → ---
You need to log in before you can comment on or make changes to this bug.