Add links to the nightly builds of all build channels and latest candidates.

RESOLVED FIXED

Status

Release Engineering
General
--
enhancement
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Joachim Herb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110804030150

Steps to reproduce:

I develop an add-on for Thunderbird and have started to add mozmill tests. 

The tests should be executed automatically by a script. For the current operating system the script downloads the different version builds of Thunderbird and the corresponding zip archives including the (mozmill) tests.

To make it easy for the script, the current versions (release, beta, aurora, comm-central) should be linked directly from the ftp://ftp.mozilla.org/pub/thunderbird/nightly/ directory.


Actual results:

At the moment there are links to ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-aurora/ and ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/ but not to the beta and release builds. The latter are (somehow) hidden in the candidate builds of which there are several versions. 


Expected results:

There should be links like latest-beta and latest-release pointing to the corresponding builds. 

The current version of the script can be found here: https://hg.mozilla.org/users/Joachim.Herb_gmx.de/compactheader/test
(Reporter)

Updated

6 years ago
Severity: normal → enhancement
Component: Release Engineering → Release Engineering
Product: mozilla.org → Mozilla Messaging
QA Contact: release → release
Created script + cron job to update latest-comm-beta and latest-comm-release symlinks.

https://hg.mozilla.org/users/john.hopkins_mozillamessaging.com/misc/file/a552237657d0/stage/symlink-latest-release.py
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
I don't like the names of these symlinks, I'm even cautious about having the latest-comm-release ones at all, because that is implying something that they shouldn't (yes, even though they are in the /nightly/ directory).

If we must have these I'd rather go with latest-candidate-comm-beta and latest-candidate-comm-release, to try and make it clearer that we might not have even released these builds to the public yet.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
standard8: I have renamed the symlinks to latest-candidate-comm-beta and latest-candidate-comm-release
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

5 years ago
This seems to be broken since the 14.0 release of Thunderbird. The latest updates were:

latest-candidate-comm-beta/	15-Aug-2012 13:46
latest-candidate-comm-release/	13-Jul-2012 19:42
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This is releng's area now.
Component: Release Engineering → Release Engineering
Product: Mozilla Messaging → mozilla.org
Summary: Add links to the nightly builds of all build channels → Add links to the nightly builds of all build channels and latest candidates.

Comment 6

5 years ago
Hrmmm, there's a reason we don't provide these links for Firefox, as Mark alludes to in comment #2.

jhopkins: is your script still running somewhere via cron?
The "latest-beta" and "latest" directories in https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/, https://ftp.mozilla.org/pub/mozilla.org/mobile/releases/ and https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/ provide this now, I think?
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.