[RFE] better looking table borders please

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
--
enhancement
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: James Lariviere, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [awd:tbl], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
DESCRIPTION:

Table borders look odd (I would like to say s*#t).

STEPS TO REPRODUCE:

view screenshot (has IE5 & Mozilla winbuild 02-05-20 renderings) and the url for
a site I work on.

ACTUAL RESULTS:

It is like the cell borders alternate every other row.  It just looks weird.


EXPECTED RESULTS:

Cell borders should have a consistant rendering.
IE5 does a nice job for borders (see screenshot).
(Reporter)

Comment 1

17 years ago
Created attachment 24586 [details]
screenshot comparing IE5 vs mozilla(2-5-01 win build) rendering

Comment 2

17 years ago
Marking NEW.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: better looking table borders please → [RFE] better looking table borders please
(Reporter)

Comment 3

17 years ago
In the site's css file I added a few rules and it "fixed" the border problem. :-)

Here is what I'm using to get mozilla to render borders like normal instead of
this ugly bordering from the screenshot.

table[border="1"] {
	border-top-color: ThreeDLightShadow;
	border-right-color: ThreeDShadow;
	border-bottom-color: ThreeDShadow;
	border-left-color: ThreeDLightShadow;
	border-style: solid;
	}
table[border="1"] tbody tr td {
	border-top-color: ThreeDShadow;
	border-right-color: ThreeDLightShadow;
	border-bottom-color: ThreeDLightShadow;
	border-left-color: ThreeDShadow;
	border-style: solid;
	}

What the HELL is causing mozilla to produce this crappy bordering?

Comment 4

17 years ago
QA contact update
QA Contact: chrisd → amar
(Reporter)

Comment 5

17 years ago
I have since changed the DTD for annuitiesnet.com (URL) to get mozilla to render
in strict mode.

I noticed that this border rendering problem exists in just quirks mode.

Comment 6

16 years ago
this works for me in quirk and strict mode. WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Whiteboard: [awd:tbl]
You need to log in before you can comment on or make changes to this bug.