Message counter reports too high number when moving messages

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
--
minor
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Patrick Julian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

Tried to move 7 messages from main inbox folder to a subfolder while automatic folder maintenance was in progress. Thunderbird rejected this by showing an error message and by keeping the mail messages in the inbox.

Inbox currently counts some 1,300 mail messages.
No plugins currently active.
Mac OS X 10.6.8 on iMac7,1 Intel Core 2 Duo 4 GB RAM.



Actual results:

Status bar showed a message (aligned on the left side) that incorrectly confirmed that 7 messages had been moved to subfolder: "7 Nachrichten von '[inbox]' nach '[subfolder]' verschoben".

After retry, the counter was increased to 14 and 21 respectively, while no message had actually been moved.


Expected results:

There should have been no such message at all, since the transaction didn't finish. Instead, there might have been a notification that moving the messages had failed (which was already made obvious by the error dialog, though).

Updated

6 years ago
Severity: normal → minor

Updated

5 years ago
Component: General → Untriaged

Comment 1

5 years ago
Do you still see this problem when using version 17 or newer?
Newer can be found at http://www.mozilla.org/en-US/thunderbird/channel/
Flags: needinfo?(spam)
Whiteboard: [closeme 2013-07-01]
(Reporter)

Comment 2

5 years ago
Thanks for checking back on this. I have seen it several times again back then but several months ago I ported my TB to a newer machine and never saw the problem again under 17.0.6. So unless someone experiences the same issue again I think I can close the ticket.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(spam)
Resolution: --- → WONTFIX

Comment 3

5 years ago
Thanks for the update.
We use WORKSFORME because you no longer see the problem
Resolution: WONTFIX → WORKSFORME
Whiteboard: [closeme 2013-07-01]
You need to log in before you can comment on or make changes to this bug.