Status

()

Firefox
Menus
--
major
RESOLVED DUPLICATE of bug 520300
7 years ago
5 years ago

People

(Reporter: Nicolas Barbulesco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Summary :

Mac OS X 10.6.8 (10K540). Firefox 5.0.
I want to copy a "mailto:" link with right click. I can't. Please add this feature. Thanks. Nicolas

Steps to reproduce :

The page http://cnrtl.fr/definition/malfaiteur contains this link :
<a href="mailto:contact@cnrtl.fr?subject=CNRTL"><img src="/images/css/PointR.jpg" alt=""/>Contact</a>
I want to copy the link address. I right-click the link.

Expected results :

There is a "Copy link" item, allowing me to copy the link address.

Actual results :

There is no "Copy link" item, so I cannot copy the link address.

Regression :

I am ready to bet that this feature existed formerly !

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353102

Comment 2

7 years ago
I duplicated it to bug 353102, because there's a "copy email address", but it only takes "contact@cnrtl.fr", it doesn't parse the whole link. In this case, only the subject is missing, but bug 353102 show more serious problems.
(Reporter)

Comment 3

7 years ago
(In reply to Jo Hermans from comment #2)

> I duplicated it to bug 353102, because there's a "copy email address", but
> it only takes "contact@cnrtl.fr", it doesn't parse the whole link. In this
> case, only the subject is missing, but bug 353102 show more serious problems.

"mailto:" is missing too.
(Reporter)

Comment 4

7 years ago
(In reply to Jo Hermans from comment #1)

> *** This bug has been marked as a duplicate of bug 353102 ***

(In reply to Jo Hermans from comment #2)

> I duplicated it to bug 353102, because there's a "copy email address", but
> it only takes "contact@cnrtl.fr", it doesn't parse the whole link. In this
> case, only the subject is missing, but bug 353102 show more serious problems.

That's not a duplicate.
Bug 353102 is about improving "Copy email address(es)".
My request bug 678927 is about "Copy link address", which is missing.
Even if "Copy email address(es)" becomes perfect and copies 10 email addresses, that will not give me the link address. I want to copy the link address, like for any normal link. With "mailto:" and the email addresses and the subject and whatever. Web browsers have been providing that simple feature for 10 years. Please bring it back. Thanks.

I particularly miss this feature because sometimes the link address is not fully shown although there is plenty of space : bug 658918.

Comment 5

7 years ago
Well ... Bug 349865 removed it, bug 520300 asks for a new version, bug wanted to improve the mailto-parser.
Duplicate of bug: 520300
(Reporter)

Updated

5 years ago
Blocks: 86194

Updated

5 years ago
No longer blocks: 86194
You need to log in before you can comment on or make changes to this bug.