If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

comment reply link doesn't work if name has a single quote

RESOLVED DUPLICATE of bug 678731

Status

()

bugzilla.mozilla.org
User Interface
RESOLVED DUPLICATE of bug 678731
6 years ago
6 years ago

People

(Reporter: al_9x, Unassigned)

Tracking

Production
x86
Windows XP

Details

(URL)

(Reporter)

Description

6 years ago
Error: missing ) after argument list
Source file: https://bugzilla.mozilla.org/show_bug.cgi?id=675840
Line: 1, Column: 37
Source code:
replyToComment(4, 5629307, 'Robert O'Callahan (:roc) (Mozilla Corporation)'); return false;

the link is document.written and single quotes are not escaped

document.write('[<a href="#add_comment" onclick="replyToComment(' +
id + ', ' + real_id + ', \'' + name +'\'); return false;">reply<' + '/a>]');

<a onclick="replyToComment(4, 5629307, 'Robert O'Callahan (:roc) (Mozilla Corporation)'); return false;" href="#add_comment">reply</a>
Assignee: create-and-change → nobody
Component: Creating/Changing Bugs → User Interface
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa → ui
Version: unspecified → Current
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 678731
You need to log in before you can comment on or make changes to this bug.