Wide font text overwrites narrow font text next to it

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
18 years ago
16 years ago

People

(Reporter: tronic2, Assigned: attinasi)

Tracking

({fonts, testcase})

Trunk
mozilla1.2alpha
x86
Windows 98
fonts, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20010131
BuildID:    2001013104

Text with wider font in middle of text written with narrow font overwrites the
narrow font text right of it.



Reproducible: Always
Steps to Reproduce:
Use the HTML-code in "Additional Information".

Following code (alone, or in proper html-file with headers) looks bad.
-- starts here --
[p align="justify"]Normal text[b]some bold(wide) text[/b]overwritten normal text
-- ends here --
I used [ and ] in this bugreport. Remember to change those.

My fonts are:
Sans: MS Sans
Sans Serif: MS Sans Serif
I can confirm this with build 2001021008. It depends on the fonts used for this
to show up, using Times new roman and Arial it works correctly. It might only
depend on the Sans font not the Sans serif but I'm not positive about that.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Created attachment 25040 [details]
Simplified test case from the code given with original report

Comment 3

18 years ago
qa contact updated.
QA Contact: gerardok → bsharma

Comment 4

18 years ago
changing the component to 'Layout'.
Assignee: clayton → karnaze
Component: HTML Element → Layout
QA Contact: bsharma → petersen
Target Milestone: --- → mozilla0.8.1

Comment 5

18 years ago
Reassigning to Pierre.
Assignee: karnaze → pierre
Target Milestone: mozilla0.8.1 → mozilla1.0

Comment 6

18 years ago
Not sure if this is related but there are many scenarios when hyperlinks are
overwritten by the text before and after them on my machine
(Linux mandrake8.0 i686) with builds for a long time till now (2001051921).
The text under the slashdot.org heading on this page is an example:
http://linuxstart.com/news.html
The links on this page exhibit it too:
http://www.mandrakesoft.com/
(there is also the text flowing to the right of the end of the table seen on
this page)
Screenshots to follow.

Comment 7

18 years ago
Created attachment 35321 [details]
Overwritten hypertext links on linuxstart

Comment 8

18 years ago
Created attachment 35322 [details]
Overwritten hypertext links and text outside table at mandrakesoft
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011022

Comment 10

17 years ago
The problem can still be reproduced on Win98 with a 2001-10-22-03 build using
the "MS Serif" or "MS Sans Serif" font at different sizes.

It looks like we don't measure the middle string with the bold attribute.
Inline Layout problem -> attinasi
Assignee: pierre → attinasi

Comment 11

17 years ago
Note: the problem was reproduced with the attached testcase but not with the 2
URLs above.

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.2
WFM using the font settings described by Pierre, Win XP Build 2002071708, with
the testcase. Can someone else re-examine?
Keywords: fonts
wfm also, marking as such.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.