[Traceback] OUnknownTimeZoneError: 'US/Pacific'

RESOLVED FIXED in 1.2

Status

developer.mozilla.org
Wiki pages
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: retornam, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: c=bug p=1, URL)

(Reporter)

Description

7 years ago
Traceback (most recent call last):

  File "/data/www/django/kuma-stage.mozilla.org/kuma/vendor/src/django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/django/kuma-stage.mozilla.org/kuma/apps/landing/views.py", line 25, in home
    'demos': demos, 'updates': updates, 'tweets': tweets})

  File "/data/www/django/kuma-stage.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 78, in render
    rendered = render_to_string(request, template, context)

  File "/data/www/django/kuma-stage.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 94, in render_to_string
    template = env.get_template(template)

  File "/data/www/django/kuma-stage.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 27, in get_template
    load_helpers()

  File "/data/www/django/kuma-stage.mozilla.org/kuma/vendor/src/jingo/jingo/__init__.py", line 121, in load_helpers
    import_module('%s.helpers' % app)

  File "/data/www/django/kuma-stage.mozilla.org/kuma/vendor/src/django/django/utils/importlib.py", line 35, in import_module
    __import__(name)

  File "/data/www/django/kuma-stage.mozilla.org/kuma/apps/users/helpers.py", line 7, in <module>
    from users.models import Profile

  File "/data/www/django/kuma-stage.mozilla.org/kuma/apps/users/models.py", line 13, in <module>
    from timezones.fields import TimeZoneField

  File "/data/www/django/kuma-stage.mozilla.org/kuma/vendor/src/django-timezones/timezones/fields.py", line 14, in <module>
    default_tz = pytz.timezone(getattr(settings, "TIME_ZONE", "UTC"))

  File "/data/dekiwiki-stage/src/kuma-stage.mozilla.org/kuma/vendor/lib/python/pytz/__init__.py", line 185, in timezone

UnknownTimeZoneError: 'US/Pacific'
I can't reproduce this, but I got the error email. Is it still happening? Was there any special conditions that trigger it?
Whiteboard: c=bug p=1
Target Milestone: --- → 1.1
Assignee: nobody → mozbugs.retornam
Raymond, have you been able to reproduce this again? Or should we INVALID or WORKSFORME it?
(Reporter)

Comment 3

7 years ago
(In reply to Luke Crouch [:groovecoder] from comment #2)
> Raymond, have you been able to reproduce this again? Or should we INVALID or
> WORKSFORME it?
I haven't been able to reproduce this. Let  us leave this open for now
Bumping to 1.2 for triage, since we're at code freeze for 1.1 and these bugs are most likely not going to make it.
Target Milestone: 1.1 → 1.2
raymond, have we seen this again? I'm ready to close it unless/until it happens again.
(Reporter)

Comment 6

7 years ago
I haven't seen traceback emails for this  in a while, please close this. I'll re-open when I am able to reproduce this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Assignee: mozbugs.retornam → nobody
(Assignee)

Updated

6 years ago
Version: Kuma → unspecified
(Assignee)

Updated

6 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.