After clicking on an Anchored links (ie #Top), Back does not return to proper position.

VERIFIED DUPLICATE of bug 59774

Status

()

Core
Document Navigation
P3
minor
VERIFIED DUPLICATE of bug 59774
17 years ago
10 years ago

People

(Reporter: Brett Stoppel, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
mozilla0.9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
After clicking on a targeted link and clicking the back button, the page does
not return to the correct place in the document. Instead it returns to the top
of the page, which is most annoying.

Comment 1

17 years ago
this is already reported I'm sure. no time to look now. 

Comment 2

17 years ago
seems to be working for me 2001020704 win98

Comment 3

17 years ago
WORKSFORME
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2001020512
Severity: major → minor

Comment 4

17 years ago
Build 2001020906 on NT4 exactly as reporter says. 

I used the link "related links" and then pressed back. A quick look in History
shows me that this page is not being written into History (link is written in
History). And so if i press back, then it goes back to the page i visited before
this site, that normal. So the question is: Why is the History not updated?"

Comment 5

17 years ago
OK i see it now..but I cant find a dupe of it but its such an obvious problem
you think there would be some dupes..maybe i am not looking in the right place.
Holding off on marking it new until i am convinced its not a dupe.
OS: Windows ME → All
Hardware: PC → All
Summary: Targeted links not working properly → After clicking on an Anchored links (ie #Top), Back does not return to proper position.

Comment 6

17 years ago
Sure, this must be a dup, searching.

Comment 7

17 years ago
Bug 47238 "Tracker bug for all Session history bugs" would be a nice place for
this one i guess.

Comment 8

17 years ago
I just cleared my History information and revisit that page. I have used build
2001021206 for this test. Now it seems to work! I now see those pages in the
history, did something change on that page or is this fixed by now??

Reporter can you please clear your history information and try once more? And
make sure to let us know Ok. Thanks.
(Reporter)

Comment 9

17 years ago
I cleared my history, and the bug is still appearing. I am using build
2001021904. The link I click on is
http://www.ukans.edu/acs/docs/dreamweaver/#Resources at the end of the fifth
full paragraph, "Web sites with HTML tutorials." After clicking on the link I
clicked on the back button. 

Comment 10

17 years ago
updating component.
Assignee: asa → radha
Component: Browser-General → History: Session
QA Contact: doronr → claudius
seeing this on win98 2001021604, confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9
In today's build, I went to tha above site, clicked on "About Dream weaver" on 
the left, clicked on "Other resources" Clicking back, brought me all the way 
properly from #resources to # dreamweaver and then to the top of the page.

Please check the Go menu to see how many entries it has created for the page. 
Anchor visits are not a known problem. (It was a problem before RTM though). The 
tools->tasks->history list has nothing to do with the behavior of the 
back/forward buttons. Please try out other sites with anchors

Comment 13

17 years ago
I was going to say this was a dupe of bg 59774 but we seem to have drifted from the
original description. So now I'm not sure exactly what observed behavior was confirmed.
I use this page to test anchors and SH:
http://www.mozilla.org/quality/browser/front-end/testcases/history/anchor-history.html

Comment 14

17 years ago
Confirming on 2001011905 Linux. Back button returns to anchor position, not
scrolled position.

I think the reporter is trying to document this behaviour:
1) Go to anchored URL
2) scroll the page
3) click a link
4) go back
5) mozilla returns to anchor, not position scrolled to in step (2).

Comment 15

17 years ago
>The tools->tasks->history list has nothing to do with the behavior of the 
>back/forward buttons.

Is there another history section for the back button, other then
tools/tasks/history? That one is new for me!

Comment 16

17 years ago
It was h-J's 20010209 comments that threw me off. If those are inaccurate then this is
just a dupe like I said.
quick seminar: global history= all the pages you've ever visited with this profile and this
browser until they expire via user controlled pref. Accessible via Task>Tools>History.
Session History= all the pages you've visited with this browser _window_. Accessible via
dropdown menus in back/forward buttons and the 'Go' menu. A strict subset of Global
History. goes away after closing window, restart, etc.

Comment 17

17 years ago
Ok, thank you Claudius, but: 

1: My session history doesn't always show all visited pages.
2: My session history, that dropdown menu, doesn't get cleared after a restart!
3: Global history doesn't get updated, or it takes a heck of a long time, when
my history file is really long, and then I mean really long.

But it seems your right, this is a dup of bug 59774

Comment 18

17 years ago
re 2: the menus under back/forward, or the 'Go' menu? IF those don't clear after restart
that a (new) bug. You might be thinking of the type-in history in the URL bar which is yet
another totally different history.


*** This bug has been marked as a duplicate of 59774 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 19

17 years ago
VERIFIED Dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.