[Firefox Beta Branding] Design New Firefox Beta Desktop Page

RESOLVED FIXED

Status

Marketing
Design
P2
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: grace, Assigned: Ty Flanagan)

Tracking

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Dedicated Firefox Beta Page
   * Discuss Firefox Beta branding
   * provide more info to new potential beta user
   * highlight benefits of being in the beta channel
   * What's new (features) in the latest beta

More details and instructions to come soon! 

Design Deadline Date: Sept. 19
Live Date: Sept. 27
(Reporter)

Comment 1

7 years ago
hi chrissie, 

please upload final wireframes. would be great to have final frames as soon as possible (no later than this week) thanks!
(Reporter)

Updated

7 years ago
Blocks: 684089
(Reporter)

Comment 2

7 years ago
hi tara, 

attached is the wireframe for the Firefox Beta page. It's the same layout as the Firefox Aurora Page. Except the look and feel would be different specifically with Firefox Aurora branding/background implemented.

Chrissie already provided some directions in the file.

Chrissie, please feel free to add any additional comments or directions if we missed anything.

I'm also attaching the rapid release pages over all sites flow.

would it possible to have the design by sept 9th? ideally, it would be great to line up the design before the all hands. 

thanks!
(Reporter)

Comment 3

7 years ago
Created attachment 558172 [details]
Firefox Beta Page
(Reporter)

Comment 4

7 years ago
Created attachment 558173 [details]
Rapid Release Pages Flow Diagram
(Reporter)

Updated

7 years ago
Blocks: 684731

Updated

7 years ago
Assignee: tshahian → tyronflanagan

Updated

7 years ago
Summary: [Rapid Release Branding] Firefox Beta Page → [Rapid Release Branding] Design New Firefox Beta Page
(Reporter)

Comment 5

7 years ago
Hi Ty, 

I wanted to revisit this bug and see if we can add this next to the list. 

thanks!

Comment 6

7 years ago
OK, here's a first pass at copy for this. It can definitely be improved upon and tightened up, but I wanted to give us something to comment on and discuss. Let me know if there are any specific points I've missed or any other thoughts.


Firefox Beta
Download Beta and be part of the next version of Firefox.

1. Test Features
Try out the latest performance, customization and security enhancements almost ready for prime time.

2. Refine & Polish
File bugs to help us put the final tweaks on performance and functionality in a stable environment.

3. Do Your Part
Have an impact on the next version of Firefox and the 450 million people who use it every day.

Comment 7

7 years ago
(In reply to Matej Novak [:matej] from comment #6)
> OK, here's a first pass at copy for this. It can definitely be improved upon
> and tightened up, but I wanted to give us something to comment on and
> discuss. Let me know if there are any specific points I've missed or any
> other thoughts.
> 
> 
> Firefox Beta
> Download Beta and be part of the next version of Firefox.
> 
> 1. Test Features
> Try out the latest performance, customization and security enhancements
> almost ready for prime time.

Prime time might not be very l10n friendly. 

> 
> 2. Refine & Polish
> File bugs to help us put the final tweaks on performance and functionality
> in a stable environment.

General release might sound more compelling than stable environment.

> 
> 3. Do Your Part
> Have an impact on the next version of Firefox and the 450 million people who
> use it every day.

LOVE LOVE LOVE

Comment 8

7 years ago
Grace, what do you think?

Perhaps this is one of those times where we have an en-US version and a l10n version? I like 'prime time' for en-US, but understand the potential localization problem.
(Reporter)

Comment 9

7 years ago
(In reply to John Slater from comment #8)
> Grace, what do you think?
> 
> Perhaps this is one of those times where we have an en-US version and a l10n
> version? I like 'prime time' for en-US, but understand the potential
> localization problem.

hi matej! the beta copy looks great!!!! i like the prime time as well. maybe we can work with the l10n in figuring out what's a more l10n friendly term. 

we should also keep the stable environment (as beta is not general release yet) and we want to emphasize that it's for people who are maybe looking to help with testing but in a more stable build. 

i think we're good with the copy. 

thanks matej!
(In reply to Grace Jimenez :grace from comment #9)

> i like the prime time as well. maybe
> we can work with the l10n in figuring out what's a more l10n friendly term. 

Maybe here's where we can use "general release" as an l10n option:

Try out the latest performance, customization and security enhancements almost ready for general release.

Comment 11

7 years ago
Created attachment 568115 [details]
Wireframe 1 for Beta for Desktop

Revised wireframe with Matej's copy attached.
Attachment #558172 - Attachment is obsolete: true
(Reporter)

Updated

7 years ago
Summary: [Rapid Release Branding] Design New Firefox Beta Page → [Firefox Beta Branding] Design New Firefox Beta Desktop Page
(Reporter)

Updated

7 years ago
Priority: -- → P1
(Reporter)

Comment 12

7 years ago
updating bug with deadline: Friday, Nov. 4th
the current wireframe that chrissie provided looks great! 

* similar to layout as the Firefox Aurora page
* updated Beta copy
* we just need to figure out what images will differentiate the desktop and mobile pages 

Ty, please let me know if you have any questions here.
(Assignee)

Comment 13

7 years ago
Are were removing the newsletter sign-up and blog posts?
(Reporter)

Comment 14

7 years ago
(In reply to Ty Flanagan from comment #13)
> Are were removing the newsletter sign-up and blog posts?

nope they should be there too.
(Reporter)

Updated

7 years ago
Priority: P1 → P2
(Assignee)

Comment 15

7 years ago
Created attachment 578419 [details]
Ffx Beta - Desktop
(Reporter)

Comment 16

7 years ago
hi ty, 

i like the idea. 
but i also want to make sure that people wont think this is the new beta logo? 
maybe we can use the firefox logo in the same treatment and design?

let me know if you have any questions, we can also include this in our discussion tomorrow morning.

Comment 17

7 years ago
Hey guys

So, as discussed:

* Really like the blueprint concept, and what Ty has done here.  Great job.

* Tricky part is that this introduces a whole new version of the logo which can cause some confusion.  And if this is going to be a new / official graphic for Firefox Beta, then that also needs some more discussion before we go live with anything.  Just want to make sure we don't rush it.  Making sure we think through how/where it fits into the larger brand architecture, what it means, how it's used, etc etc. 

* I think if it was a different image (not the logo) it would be simpler... similar to other promo graphics/illustrations we've used which support the product but don't really conflict with or alter the logo.  Obviously we've had some challenges with the Beta channel branding and the FF logo (+ beta sash) etc... which is related but a separate discussion...   for this, I think it would be nice to see what else we've tried (I haven't seen other creative explorations) and see if we can come up with another solution until we figure out how we want to approach the FF beta branding. 

I know that doesn't help much, and it repeats what has already been said.  But just wanted to follow up as promised.   cc-ing / pinging Slater and Sean to continue the conversation here and have them weigh in on the bug since email is down.

Comment 18

7 years ago
I have to agree with Tara in comment #17. I really like the blueprint concept and the way it turned out, but am not sure that's the visual we want to use as our main beta image. If it were only for this page, it'd probably be fine, but for the sake of consistency it would be best if we repeated it everywhere beta is promoted.

Complicating matters further is the fact that the whole branding around beta is pretty complex...having to use the same logo/icon for both the beta & GA products drives me a little crazy (but also seems pretty unavoidable at this point).

So, my vote would be to explore other possibilities so we have other options to choose from. Am happy to meet as a small group if that would help.

Comment 19

7 years ago
Thanks Tara and John for the insightful comments above. 

We keep bumping into this problem: how to give the Beta product a distinct visual identity - so it's worth taking a step back and coming up with a solution. 

I'm happy to meet and help this along in any way I can.
(Assignee)

Comment 20

7 years ago
Created attachment 579937 [details]
Ffx Beta - Background Options

Comment 21

7 years ago
I'd like to be in those conversations as well :)  Not sure what the next step is here (would someone like to set up a meeting to discuss?) and if we can realistically find a solution before the intended go-live date of these beta sites. 

So, one possible solution in the interim is to do a design that doesn't augment the logo too much (causing confusion around a new logo and/or possibly stirring up demand for logo art that people want on t-shirts, etc  but was intended as a temporary thing --> like the outlined beta graphic we did a while back).  Perhaps something like one of Ty's new solutions where it's a more diluted version of the logo. 

Another option is to do a site design that we feel good about from a layout perspective, navigation, etc.  But isn't as visually exciting as we had hoped.  At least the new site is launched, beta has a strong presence, and we can work towards updating it with the proper hero graphic / branding when we figure that out.  Not ideal, but it's an option that allows us to go live with something while we pursue these heavier conversations around beta branding.

I'd also be curious to learn more about options to change the beta icon that's actually downloaded.  I mean, I really like the blueprint concept, for example, I could see an icon in that style work well for beta, perhaps.  It's similar to what Chrome does of course, and I'm not saying that's our solution, but I think it's worth discussing a different version of the logo for the icon that could then be used for the branding.  Or we go towards another conceptual representaion of beta (spaceships, biospheres, robots, etc) which addresses one issue (branding) and not the other (icon conflict with GA).

Comment 22

7 years ago
I like the 2nd and 4th logos in Ty's graphics in Comment 20.

They're clearly the Firefox logo, but subtly different and distinct, like Beta. 

I think either works for this page at hand, but the larger question of if this new diluted version can be rolled out to other touch-points.

Comment 23

7 years ago
Tara - John - any thoughts on Comment 22?

Comment 24

7 years ago
I think it's okay to use one of those "diluted" versions of the logo for here, but with plans to meet and figure out a real solution soon.  If we start using something across all materials it'll start to feel like the official visual identity for Beta whether we intended it to be that or not.  So, we should be careful about where it's used... I think a limited roll out for purposes of getting this site up makes sense, but not a sudden revamp of all Beta materials.

Comment 25

7 years ago
Agreed with what Tara said in comment #24. To sum up:

- I like option 2 from comment #20 (thanks Ty)
- we should have a broader conversation about beta imagery going forward
- no need to block this bug any further by issues that are beyond its scope
(Reporter)

Comment 26

7 years ago
thanks Laura, Tara and Slater. 

Ty, let's update with beta pages with option 2 for now (beta notes page as priority).

Thanks all!

Updated

7 years ago
Status: NEW → ASSIGNED

Comment 27

7 years ago
Sounds good. Ty - please post once done. WebDev is ready to start 'a codin'.
(Assignee)

Comment 28

7 years ago
PSD with the updated logo background.
(Reporter)

Comment 30

7 years ago
thanks ty!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 31

7 years ago
Created attachment 583637 [details]
Ffx Beta - Desktop - Version 2/Alt

PSD:
http://mozilla.tyflanagan.com/artwork/Beta/FFx_Beta_Desktop_v2.psd.zip
You need to log in before you can comment on or make changes to this bug.