[5xx Error] - File: application/libraries/drivers/Database/Pgsql.php; Line: 74; Message: pg_query(): Query failed: server closed the connection unexpectedly

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
7 years ago
7 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
On stage, I've been easily causing the server to close connections, by running queries like:

https://crash-stats.allizom.org/report/list?version=Firefox%3A6.0b5&query_search=signature&query_type=contains&reason_type=contains&date=2011-08-15&range_value=28&range_unit=days&hang_type=any&process_type=any&signature=RtlpWorkerCallout

[5xx Error] File: application/libraries/drivers/Database/Pgsql.php; Line: 74; Message: pg_query(): Query failed: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
2011-08-16 03:03:48 -07:00 --- error: [5xx Error] File: application/libraries/drivers/Database/Pgsql.php; Line: 364; Message: There was an SQL error: server closed the connection unexpectedly
	This probably means the server terminated abnormally
	before or while processing the request.
Flags: in-testsuite?
Flags: in-litmus?

Comment 1

7 years ago
Ideas for tuning, josh?

Comment 2

7 years ago
These are caused by running deliberately expensive queries: not for 2.2.1
Target Milestone: --- → 2.3
I'm pretty sure this was just from us having DB problems during the 2.2 cycle, any problems since?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
thx for filing the boog. Bumping to verified workforme per comment 3.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.