Inconsistent results-count for query for 'RtlpWorkerCallout'

VERIFIED FIXED in 2.2

Status

Socorro
General
--
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: stephend, Assigned: rhelmer)

Tracking

Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 553420 [details]
Screenshot showing 430 results for 'RtlpWorkerCallout'

https://crash-stats.allizom.org/query/query?product=Firefox&version=Firefox%3A6.0b5&range_value=1&range_unit=weeks&date=08%2F16%2F2011+02%3A59%3A59&query_search=signature&query_type=contains&query=RtlpWorkerCallout&reason=&build_id=&process_type=any&hang_type=any&do_query=1 yields me 430 results

but clicking through gives me 650:

https://crash-stats.allizom.org/report/list?product=Firefox&version=Firefox%3A6.0b5&query_search=signature&query_type=contains&query=RtlpWorkerCallout&reason_type=contains&date=08%2F16%2F2011%2002%3A59%3A59&range_value=1&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=RtlpWorkerCallout
(Reporter)

Comment 1

6 years ago
Created attachment 553421 [details]
Screenshot showing 650 results for 'RtlpWorkerCallout', after clicking through...
(Reporter)

Updated

6 years ago
Flags: in-testsuite?
Flags: in-litmus?
(Reporter)

Updated

6 years ago
Assignee: nobody → rhelmer
Target Milestone: --- → 2.2
(Assignee)

Comment 2

6 years ago
Created attachment 553422 [details] [diff] [review]
put extra "OR" clause in an else

With this patch, the counts match up to 430 on my dev instance. 

hard to see in UI, I dumped the SQL and did a count(*):
breakpad=> select count(*)
                   FROM   reports JOIN  product_versions ON reports.version = product_versions.release_version AND reports.product = product_versions.product_name LEFT OUTER JOIN  reports_duplicates ON reports.uuid = reports_duplicates.uuid WHERE  reports.signature = 'RtlpWorkerCallout' AND (reports.product = 'Firefox' AND product_versions.version_string = '6.0b5' AND reports.version = product_versions.release_version AND reports.release_channel ILIKE 'beta' AND product_versions.build_type = 'beta' AND EXISTS ( SELECT 1 FROM product_version_builds WHERE product_versions.product_version_id = product_version_builds.product_version_id AND build_numeric(reports.build) = product_version_builds.build_id )) AND reports.signature  LIKE '%RtlpWorkerCallout%' AND reports.date_processed BETWEEN CAST('08/16/2011 02:59:59' AS TIMESTAMP WITHOUT TIME ZONE) - CAST('1 weeks' AS INTERVAL) AND CAST('08/16/2011 02:59:59' AS TIMESTAMP WITHOUT TIME ZONE); count 
-------   
430
(1 row)
Status: NEW → ASSIGNED
Attachment #553422 - Flags: review?(chris.lonnen)
(Assignee)

Comment 3

6 years ago
Created attachment 553424 [details] [diff] [review]
put extra "OR" clause in an else
Attachment #553422 - Attachment is obsolete: true
Attachment #553422 - Flags: review?(chris.lonnen)
Attachment #553424 - Flags: review?(chris.lonnen)
(Assignee)

Comment 4

6 years ago
Created attachment 553436 [details] [diff] [review]
put extra "OR" clause in an else, get precedence right

OK I've tested this with:
* topcrasher links (off by a little bit, expected)
* old search -> report clickthrough (count matches)
* new beta search -> report clickthrough (count matches)
* new release search -> report clickthrough (count matches)

Doing multi-version search should work too, but the query takes a _very_ long time on stagedb.
Attachment #553424 - Attachment is obsolete: true
Attachment #553424 - Flags: review?(chris.lonnen)
Attachment #553436 - Flags: review?(chris.lonnen)
(Assignee)

Comment 5

6 years ago
Created attachment 553437 [details] [diff] [review]
put extra "OR" clause in an else, get precedence right
Attachment #553436 - Attachment is obsolete: true
Attachment #553436 - Flags: review?(chris.lonnen)
Attachment #553437 - Flags: review?(chris.lonnen)

Comment 6

6 years ago
Comment on attachment 553437 [details] [diff] [review]
put extra "OR" clause in an else, get precedence right

Difficult to test because of the database situation, but the code looks good and the errors I encounter are from the db, not this patch.
Attachment #553437 - Flags: review?(chris.lonnen) → review+
(Assignee)

Comment 7

6 years ago
Landed on trunk:
Committed revision 3461.

Landed on 2.2 branch:
Committed revision 3462.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

6 years ago
(In reply to Robert Helmer [:rhelmer] from comment #4)
> Doing multi-version search should work too, but the query takes a _very_
> long time on stagedb.

I take this last part back; I don't think this code has ever been right in this case. I'll file a followup bug specifically about this.
QA verified. Good find stephend. The returned result counts add up correctly now. I verified this with several different products and releases.

Steps to reproduce (comment 0):

https://crash-stats.allizom.org/query/query?product=Firefox&version=Firefox%3A6.0b5&range_value=1&range_unit=weeks&date=08%2F16%2F2011+02%3A59%3A59&query_search=signature&query_type=contains&query=RtlpWorkerCallout&reason=&build_id=&process_type=any&hang_type=any&do_query=1 yields me 430 results

and clicking through gives 430:

https://crash-stats.allizom.org/report/list?product=Firefox&version=Firefox%3A6.0b5&query_search=signature&query_type=contains&query=RtlpWorkerCallout&reason_type=contains&date=08%2F16%2F2011%2002%3A59%3A59&range_value=1&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=RtlpWorkerCallout
Status: RESOLVED → VERIFIED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.