IonMonkey: Linear scan register allocator allocates registers for output half of instruction at end of interval

RESOLVED DUPLICATE of bug 709731

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 709731
7 years ago
6 years ago

People

(Reporter: adrake, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Currently, uses result in live intervals that span an entire instruction. As a result, they can get split at the output half of instructions that have MUST_REUSE_INPUT policies and get assigned registers for no reason. Fixing this would eliminate effectively one move per virtual register.
Fixed in bug 709731.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 709731
You need to log in before you can comment on or make changes to this bug.