Shortened URL that links to image confuses Save Image As

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: mozilla.org, Unassigned)

Tracking

(Depends on: 1 bug)

SeaMonkey 2.2 Branch

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2
Build ID: 20110706013215

Steps to reproduce:

When a shortened URL (e.g. a t.co link) points directly to an image, the Save As dialog box gets confused.

For example, go to 

http://t.co/A7akk11

This is a shortlink to 

http://www.microbot.ch/html5/images/19.jpg

Now right-click on the image and do Save Image As ...

You will be prompted to save A7akk11.htm, not 19.jpg.  And when you do save it, what you get is not a JPEG image file, but something else.
I opened http://t.co/A7akk11 and I get a 301 redirect to "Location:	http://www.microbot.ch/html5/images/19.jpg". 
Right clicking on the image and selecting "save image as" and SM wants to save "A7akk11.jpg" and the saving works.
-  Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110813 Firefox/8.0a1 SeaMonkey/2.5a1
(Reporter)

Comment 2

7 years ago
Well, the filename is 19.jpg, not A7akk11.jpg.  If you shift-reload the page, Save Image As... works normally.

On OS X, it wants to save it as A7akk11.htm, even though it is a jpeg file.  Renaming it to A7akk11.jpg makes it load normally in any app.

So maybe the problem is with the 301 redirection, and not necessarily the URL shortener.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311742

Comment 4

7 years ago
> http://t.co/A7akk11

Right-click link, Save /Link/ Target As..., returns 19.jpg.

Opening link, Save /Image/ As..., returns 19.jpg.
(Also confirming that 2.5 returns A7akk11.jpg.  Wonder why?  Must be because in a change in how it determines, or what is uses as, the file "name".)

Is there a web page with a shortened link & maybe the /page/ is reporting that the link is (type) whatever/jpeg (I don't know html), but in fact, the "jpeg" is only the pointer to the redirect & not the actual image, & so that is why a "Save Image As" (which I'm not even seeing without actually having already opened the image) is coming down as this "A7akk11.jpg" or "A7akk11.jpg.htm" (as is likely the case).

If you open this A7akk11.jpg, what is in there (suspect html code showing the redirect to http://www.microbot.ch/html5/images/19.jpg)?

(Since I was in the process, I'll post anyhow, even though I see it is now DUP'd.)


Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20110813 Firefox/6.0 SeaMonkey/2.3
Bug 311742 is a Firefox bug, which was moved _from_ Core _to_ Firefox (see bug 311742 comment #3), so presumably in forked code.
Status: RESOLVED → REOPENED
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Resolution: DUPLICATE → ---
Component: General → Download & File Handling
QA Contact: general → download

Updated

7 years ago
Status: REOPENED → NEW
Depends on: 311742
(Reporter)

Comment 6

7 years ago
This appears to be fixed in the latest beta.  Can anyone confirm?

Comment 7

5 years ago
> This appears to be fixed in the latest beta.  Can anyone confirm?
Looks like it's fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.