Should we reduce the indentation of <li>?

VERIFIED WONTFIX

Status

()

--
minor
VERIFIED WONTFIX
18 years ago
18 years ago

People

(Reporter: tapio.markula, Assigned: karnaze)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I put at this way to http://www.nic.fi/~tapio1/Teaching/CSSNotes.html#DL

Mozilla 0.7 calculates the margin property to LI differently as MS IE and Opera. It starts calculating from the default (30 pixel) value of the element, but defining the margin with CSS in Opera and IE reset the margin ignoring the default value. In my mind Opera and MS IE works more consistent.

In my mind the interpretation of Netscape just cause headashe to wed-designers!
Because in your mind the interpretation is correct, this headashe might be permament. Frustrating.
Could you please attach a testcase demonstrating what you believe is an
incorrect rendering of LI elements?  and maybe a ascreenshot of what opera does
with it?
I don't know what is mean here, but is you set
ul {
  margin-left: 0;
}
in IE 5 for Mac, the text in the list items becomes aligned with normal 
paragraphs and the bullets are placed to the left of the left edge of the 
paragraphs (and the list item text). The same rule has no effect in Mozilla, 
because in Mozilla the margin-left property of <ul> is already 0 (see html.css) 
and the item indentation apparently handled using a non-standard -moz-float-
edge property.
IE 5 for Windows handles margin-left of <ul> the same way as IE 5 for Mac.
If you look at the definition of ul in html.css, you see:

ul, menu, dir {
  display: block;
  list-style-type: disc;
  margin: 1em 0;
  padding-left: 40px;
  counter-reset: -html-counter 0;
}

the "padding-left: 40px" is what is causing the offset of the LI elements.  

setting "ul { margin: 0; padding: 0}" will create the behavior you want in
Mozilla (the margin: 0 is there for IE/Opera/other browsers that have a left
margin on ul instead of left padding).

Comment 5

18 years ago
The informative sample stylesheet for HTML 4.01 given in CSS2 gives:

OL, UL, DIR,
MENU, DD        { margin-left: 40px }

I'm guessing that has the same effect as what we do. Question is, do we want to
reduce the indentation size or not? Updating summary to reflect the question.
All/All/Minor. CC dbaran, hixie who may provide input.
Severity: normal → minor
OS: other → All
Hardware: Other → All
Summary: The element LI → Should we reduce the indentation of <li>?

Comment 6

18 years ago
Removing hixie since he seems to be invisibly cc'ed already.
See bug 2038 for why we use padding rather than margin.

Comment 8

18 years ago
Marking NEW while you guys sort it out.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug was not about indentation size.  It was about the fact that setting
margin:0 on the UL does not get rid of the indentation.  Since we indent using
padding, not margin, and have good reasons for it, I suggest WONTFIX.
Since this bug was confirmed, marking WONTFIX to get it off the radar.  Please
reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
VERIFIED. If we change this we'll be breaking backwards-compatability in ways we
probably can't even think of.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.