fix tegra dashboard for new staging server

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: bear, Assigned: bear)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [android][tegra])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

6 years ago
tegra dashboard has a real simple check for what is production/staging - that needs to be updated with the shift from bm-foopy to staging-master
(Assignee)

Updated

6 years ago
Assignee: nobody → bear
Whiteboard: [android][tegra]
(Assignee)

Comment 1

6 years ago
Created attachment 553528 [details] [diff] [review]
update staging master name

change check.py so it knows what the new staging master is and also update dashboard for the new name (and also the change I made for the activity display)
Attachment #553528 - Flags: review?(aki)
Comment on attachment 553528 [details] [diff] [review]
update staging master name

staging-master is going away.
Also, we want to be able to run tegras in any staging master, not just one instance.

Not sure what to do on the dashboard, but check.py should be at least able to look for dev or staging.
Attachment #553528 - Flags: review?(aki) → review-
(Assignee)

Updated

6 years ago
Duplicate of this bug: 692787
(Assignee)

Comment 4

6 years ago
Created attachment 570398 [details] [diff] [review]
combo patch for master name, tegras.json usage and pdu name change

fixes tegra master and pdu for dashboard.py and check.py
bug 697325 - change pdu links
Attachment #570398 - Flags: review?(aki)
(Assignee)

Updated

6 years ago
Attachment #553528 - Attachment is obsolete: true
Comment on attachment 570398 [details] [diff] [review]
combo patch for master name, tegras.json usage and pdu name change

Is this running somewhere, or can I see the output somewhere?
(Assignee)

Comment 6

6 years ago
I have it running live now (backed up the older one) - unfortunately it's the only way to truly test it
(Assignee)

Comment 7

6 years ago
(In reply to Mike Taylor [:bear] from comment #6)
> I have it running live now (backed up the older one) - unfortunately it's
> the only way to truly test it

tho what you may not see is the proper production/staging classification as that depends on the check.py changes to be pushed to foopies.  Let me push that to foopy5 and 6 so they can test that part
(Assignee)

Comment 8

6 years ago
Created attachment 570426 [details] [diff] [review]
combo patch for master name, tegras.json usage and pdu name change

tested on foopy05 and on live dashboard
Attachment #570426 - Flags: review?(aki)
Attachment #570426 - Flags: review?(aki) → review+
(Assignee)

Updated

6 years ago
Attachment #570398 - Attachment is obsolete: true
Attachment #570398 - Flags: review?(aki)
(Assignee)

Comment 9

6 years ago
Comment on attachment 570426 [details] [diff] [review]
combo patch for master name, tegras.json usage and pdu name change

committed changeset 1901:5b388599864f
Attachment #570426 - Flags: checked-in+
(Assignee)

Comment 10

6 years ago
pushed live
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.