Last Comment Bug 679467 - scratchpad doesn't display the value false
: scratchpad doesn't display the value false
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 6 Branch
: x86 Mac OS X
: P2 normal (vote)
: Firefox 10
Assigned To: Heather Arthur [:harth]
:
:
Mentors:
: 690569 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-16 12:45 PDT by Allen Wirfs-Brock
Modified: 2011-11-03 18:46 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
display falsy values (12.00 KB, patch)
2011-11-02 15:28 PDT, Heather Arthur [:harth]
rcampbell: review+
Details | Diff | Splinter Review

Description Allen Wirfs-Brock 2011-08-16 12:45:03 PDT
The 'display' menu item does not display the values of false, null, "", etc.  It appears to skip displaying all falsey values.  This is not what I would want to see, as a user of this feature.  Please display the actual value.

Repo:
1) open a scratchpad
2) type: false
3) select it and then select the 'display' menu item
4) no output appears
Comment 1 Dave Camp (:dcamp) 2011-10-27 09:19:27 PDT
We're doing developer tool prioritization, filter on 'brontozaur'
to ignore the spam.
Comment 2 Mihai Sucan [:msucan] 2011-10-27 09:32:17 PDT
*** Bug 690569 has been marked as a duplicate of this bug. ***
Comment 3 Heather Arthur [:harth] 2011-10-27 17:37:10 PDT
I imagine we'd want to do this for the 'inspect' command too?
Comment 4 Heather Arthur [:harth] 2011-11-02 15:28:46 PDT
Created attachment 571479 [details] [diff] [review]
display falsy values

This patch makes scratchpad inspect and display all falsy values.
Comment 5 Rob Campbell [:rc] (:robcee) 2011-11-03 07:14:37 PDT
Comment on attachment 571479 [details] [diff] [review]
display falsy values

In test file:

+function testFalsy(sp)
+{
+  gScratchpadWindow.removeEventListener("load", arguments.callee, false);

should removeEventListener("load", testFalsy, false) as arguments.callee is going away.
Comment 6 Rob Campbell [:rc] (:robcee) 2011-11-03 07:19:24 PDT
Comment on attachment 571479 [details] [diff] [review]
display falsy values

looks good!
Comment 7 Rob Campbell [:rc] (:robcee) 2011-11-03 08:50:54 PDT
and the REAL push:

https://hg.mozilla.org/integration/fx-team/rev/0447ea74c626
Comment 8 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-03 18:46:54 PDT
and the REAL push to m-c :)

https://hg.mozilla.org/mozilla-central/rev/0447ea74c626

Note You need to log in before you can comment on or make changes to this bug.