[traceback] OperationalError: (1054, "Unknown column 'addons.manifest_url' in 'field list'")

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
7 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
preview is down

Traceback (most recent call last):

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-mobility/mobility/decorators.py", line 49, in wrapper
   return normal_fn(request, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/addons/views.py", line 447, in impala_home
   'src': 'homepage', 'collections': collections})

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 79, in render
   rendered = render_to_string(request, template, context)

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 97, in render_to_string
   return template.render(**get_context())

 File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/amo_python/www/preview/zamboni/apps/addons/templates/addons/impala/home.html", line 8, in top-level template code
   {% set view_all = {

 File "/data/amo_python/www/preview/zamboni/templates/impala/base.html", line 144, in top-level template code
   {% block main_content %}

 File "/data/amo_python/www/preview/zamboni/templates/impala/base.html", line 149, in block "main_content"
   {% block content %}{% endblock %}

 File "/data/amo_python/www/preview/zamboni/apps/addons/templates/addons/impala/home.html", line 40, in block "content"
   {% cache popular %}

 File "/data/amo_python/www/preview/zamboni/apps/amo/ext.py", line 22, in _cache_support
   return sup(key, obj, timeout, extra, caller)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-cache-machine/caching/ext.py", line 74, in _cache_support
   return caching.base.cached_with(obj, caller, key, timeout)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-cache-machine/caching/base.py", line 284, in cached_with
   return cached(f, key, timeout)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-cache-machine/caching/base.py", line 264, in cached
   val = function()

 File "/data/amo_python/www/preview/zamboni/apps/addons/templates/addons/impala/home.html", line 45, in template
   {{ popular|addon_toplist(src='hp-dl-mostpopular') }}

 File "/data/amo_python/www/preview/zamboni/vendor/src/jingo/jingo/__init__.py", line 147, in wrapper
   t = env.get_template(template).render(context)

 File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
   return self.environment.handle_exception(exc_info, True)

 File "/data/amo_python/www/preview/zamboni/apps/addons/templates/addons/impala/toplist.html", line 2, in top-level template code
   {% for addon in addons %}

 File "/usr/lib/python2.6/site-packages/jinja2/runtime.py", line 282, in __init__
   self._length = len(iterable)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/db/models/query.py", line 84, in __len__
   self._result_cache.extend(self._iter)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-cache-machine/caching/base.py", line 102, in __iter__
   obj = iterator.next()

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-cache-machine/caching/base.py", line 168, in fetch_by_id
   new = dict((byid(o), o) for o in others)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/db/models/query.py", line 89, in __iter__
   self._iter = self.iterator()

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-cache-machine/caching/base.py", line 135, in iterator
   return iter(iterator())

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-queryset-transform/queryset_transform/__init__.py", line 20, in iterator
   results = list(result_iter)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/db/models/query.py", line 273, in iterator
   for row in compiler.results_iter():

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/db/models/sql/compiler.py", line 695, in results_iter
   for rows in self.execute_sql(MULTI):

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/db/models/sql/compiler.py", line 750, in execute_sql
   cursor.execute(sql, params)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/db/backends/mysql/base.py", line 86, in execute
   return self.cursor.execute(query, args)

 File "/usr/lib/python2.6/site-packages/MySQLdb/cursors.py", line 173, in execute
   self.errorhandler(self, exc, value)

 File "/usr/lib/python2.6/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
   raise errorclass, errorvalue

OperationalError: (1054, "Unknown column 'addons.manifest_url' in 'field list'")
This is now also happening on the homepage of https://addons-dev.allizom.org, but I can't reproduce it any longer on https://addons.allizom.org.
OS: Mac OS X → All
Hardware: x86 → All
Probably just needed to run schematic. I think this is fixed now.
(In reply to Jeremy Orem [oremj@mozilla.com] from comment #2)
> Probably just needed to run schematic. I think this is fixed now.

Still getting the same tracebacks; didn't seem to help :-(
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Verified WFM, now.  I filed bug 681351 on a new bug we're seeing on addons-dev.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.