Arguments object bugs within closure in Firefox5 (regression of bug 647425)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: claudio.procida, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: js-triage-needed)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

I was able to reproduce bug 6472425 in Firefox 5.0. It looks like regression from FF4.0.1.

User-Agent:  "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1"
Build Identifier: "20110707182747"

(function() {
		var args = arguments;
		function n() {
				args[0] = "caimc";
				alert.apply(null, args);
		}
		setTimeout(n,0);
})("cmc");

IN FF5.0.1 it alert undefined - should be ‘caimc’!

Reproducible: Always

Steps to Reproduce:
1.execute the code at details

Actual Results:  
undefined

Expected Results:  
caimc
(Reporter)

Updated

7 years ago
See Also: → bug 647425
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 478174
Is this really a duplicate of an ancient bug?  I sort of doubt it.

In particular, the attached testcase works for me in Firefox 3.6, fails in Fx4 and Fx5, and passes again in Fx6....  So it does look like something regressed and then was fixed.  Can we add a testcase for it?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Can someone get us the full regression history on this test case?
Keywords: regressionwindow-wanted
Whiteboard: js-triage-needed

Updated

7 years ago
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.