Startup crash [@ cairo_d2d_present_backbuffer ] with nVidia Optimus

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Potato, Assigned: bas)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {crash})

8 Branch
x86_64
Windows 7
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox8+)

Details

(Whiteboard: [tbird crash][fixed in NVIDIA driver 8.17.12.6830], crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110817 Firefox/9.0a1
Build ID: 20110817061121

Steps to reproduce:

Updated Firefox Nightly


Actual results:

It crashed when switching to the dedicated graphics card (nVidia GT325M). It didn't work after an update in Nightly (I believe 8-16), but just now I updated to Firefox Nightly 9, but it still does it.


Expected results:

It should of switched to the dedicated graphics card and opened up Firefox like usual. I also have the Firefox Release Channel and the Firefox Aurora Channel installed, and they both work fine with nVidia Optimus.
(Reporter)

Comment 1

7 years ago
It's not really a deal breaker, since I can use the Integrated Graphics card with Nightly and it works, but I'd rather use the Dedicated One since it is far superior with Hardware Acceleration and other things.
Severity: normal → critical
(Reporter)

Updated

7 years ago
Component: General → Build Config
Component: Build Config → Graphics
Product: Firefox → Core
QA Contact: general → thebes

Comment 2

7 years ago
Please post the contents of about:support (at least the Graphics section).
(Reporter)

Comment 3

7 years ago
Adapter Description: Intel(R) HD Graphics 

Vendor ID:  8086

Device ID:  0046

Adapter RAM:  Unknown

Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32

Driver Version:  8.15.10.2361

Vendor ID (GPU #2):  10de

Device ID (GPU #2): 0a35

Adapter RAM (GPU #2): 1024

Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

Driver Version (GPU #2): 8.17.12.6776

Driver Date (GPU #2): 3-17-2011

Direct2D Enabled:  true

DirectWrite Enabled:  true (6.1.7601.17563)

ClearType Parameters:  ClearType parameters not found

WebGL Renderer:  Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)

GPU Accelerated Windows: 1/1 Direct3D 10
(Reporter)

Comment 4

7 years ago
Oh and here is the Crash Report.

[url]https://crash-stats.mozilla.com/report/index/bp-987f72d2-6835-4223-8436-dbe262110817[/url]

Updated

7 years ago
Crash Signature: [@ cairo_d2d_present_backbuffer ]
Summary: Firefox Nightly does not work with nVidia Optimus. → Firefox Nightly does not work with nVidia Optimus. Crash [@ cairo_d2d_present_backbuffer ]

Comment 7

7 years ago
This is the 90-th top crasher in Firefox 8 over the past week.
Confirming based on crash data.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is probably more important than it's top crash ranking because it affects a smaller set of people all the time.
Assignee: nobody → bas.schouten
tracking-firefox8: --- → ?
(Reporter)

Comment 10

7 years ago
You could say this is fixed, because I just looked at the nVidia site, and new drivers were released on the ninth. I updated to them and now Firefox works fine.
(In reply to Potato from comment #10)
> You could say this is fixed, because I just looked at the nVidia site, and
> new drivers were released on the ninth. I updated to them and now Firefox
> works fine.

Perhaps we should blacklist the old drivers on optimus hardware?
(In reply to Potato from comment #10)
> You could say this is fixed, because I just looked at the nVidia site, and
> new drivers were released on the ninth. I updated to them and now Firefox
> works fine.

Sure sounds like it.

Potato: what is about:support saying now that you upgraded NVIDIA drivers?
(Reporter)

Comment 13

7 years ago
Adapter Description
Intel(R) HD Graphics
Vendor ID
8086
Device ID
0046
Adapter RAM
UnknownAdapter 
Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.10.2361
Driver Date
4-10-2011
Vendor ID (GPU #2)
10de
Device ID (GPU #2)
0a35
Adapter RAM (GPU #2)
1024
Adapter Drivers (GPU #2)
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version (GPU #2)
8.17.12.8026
Driver Date (GPU #2)
8-3-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows
1/1 Direct3D 10

Updated

7 years ago
Whiteboard: [tbird crash]

Updated

6 years ago
tracking-firefox8: ? → +

Comment 14

6 years ago
It's #9 top crasher in 8.0b1 where it is a startup crash.
(Assignee)

Updated

6 years ago
Depends on: 656589

Updated

6 years ago
Summary: Firefox Nightly does not work with nVidia Optimus. Crash [@ cairo_d2d_present_backbuffer ] → Startup crash [@ cairo_d2d_present_backbuffer ] with nVidia Optimus

Comment 15

6 years ago
It's #10 top crasher in 8.0.
It's correlated to the NVIDIA driver versions up to 8.17.12.6776:
     95% (528/555) vs.   1% (1023/95929) nvumdshim.dll
          6% (35/555) vs.   0% (40/95929) 8.17.12.6577
          1% (3/555) vs.   0% (3/95929) 8.17.12.6580
          3% (18/555) vs.   0% (25/95929) 8.17.12.6583
          2% (9/555) vs.   0% (10/95929) 8.17.12.6589
         35% (196/555) vs.   0% (204/95929) 8.17.12.6594
          6% (33/555) vs.   0% (33/95929) 8.17.12.6596
         15% (81/555) vs.   0% (85/95929) 8.17.12.6601
          0% (1/555) vs.   0% (1/95929) 8.17.12.6608
          0% (1/555) vs.   0% (1/95929) 8.17.12.6635
         24% (135/555) vs.   0% (146/95929) 8.17.12.6658
          3% (16/555) vs.   0% (16/95929) 8.17.12.6776
          0% (0/555) vs.   0% (12/95929) 8.17.12.6830
          0% (0/555) vs.   0% (3/95929) 8.17.12.6839
          0% (0/555) vs.   0% (4/95929) 8.17.12.6871
          0% (0/555) vs.   0% (4/95929) 8.17.12.6874
          0% (0/555) vs.   0% (6/95929) 8.17.12.6883
          0% (0/555) vs.   0% (4/95929) 8.17.12.7061
          0% (0/555) vs.   0% (3/95929) 8.17.12.7073
          0% (0/555) vs.   0% (1/95929) 8.17.12.7089
          0% (0/555) vs.   0% (1/95929) 8.17.12.7527
          0% (0/555) vs.   0% (82/95929) 8.17.12.7533
          0% (0/555) vs.   0% (1/95929) 8.17.12.7548
          0% (0/555) vs.   0% (1/95929) 8.17.12.7550
          0% (0/555) vs.   0% (89/95929) 8.17.12.8026
          0% (0/555) vs.   0% (27/95929) 8.17.12.8562
Keywords: crash
Whiteboard: [tbird crash] → [tbird crash][fixed in NVIDIA driver 8.17.12.6830]

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Why was this resolved?
Bug 701512 might help determine what's going on here.

Comment 18

6 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #16)
> Why was this resolved?
Because according to crash correlations, there have been no crashes since NVIDIA driver 8.17.12.6830. Comment 10 has also confirmed it.
If you want to blacklist old NVIDIA driver versions on Optimus HW, file a new bug.

Updated

6 years ago
Depends on: 702215

Comment 19

6 years ago
The thing is, many laptop users can't get that driver. I tried to download it from NVIDIA and it refused to install and said I had to get the drivers from Toshiba, who won't provide a newer driver than the one I already had. Running Firefox on the Intel graphics works, but I don't consider it ideal.
I believe laptopvideo2go.com offers some driver packages with Optimus support that should support all cards. Of course, that's hardly an official channel.

Comment 21

6 years ago
This widespread issue in Firefox 8 is probably a consequence of the Upgrade prompt in Firefox 3.6.
The first thing a user will think about is to downgrade to 3.6, so the blocklist is required.

Comment 22

6 years ago
Reopening as long as the blocklist is not effective.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

5 years ago
Blocks: 605749
Closing this report as this no longer shows up for supported versions.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.