Closed Bug 679873 Opened 9 years ago Closed 5 months ago

Automatically select newly created account, when created from Account Manager

Categories

(MailNews Core :: Account Manager, enhancement, minor)

enhancement
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 71.0

People

(Reporter: BenB, Assigned: aceman)

References

Details

(Keywords: polish)

Attachments

(1 file)

3.72 KB, patch
jorgk-bmo
: review+
iann_bugzilla
: review+
aceman
: feedback?
BenB
aceman
: feedback?
neil
Details | Diff | Splinter Review
Reproduction:
1. Have several accounts already set up
2. Go to Edit|Account Settings... window, select an account
3. Click button Account Actions | Add Mail Account...
4. Walk through wizard, finish it successfully

Actual result:
- The account selected in step 2 is still selected

Expected result:
- The newly created account is selected
Duplicate of this bug: 580297
Sure, let's do this. This will be consistent with the behaviour of the filter list editor and the identity list editor.

One complication is that the account is created in a new dialog so I hope I can get from it which account was created.
Assignee: nobody → acelists
Keywords: polish
Product: Thunderbird → MailNews Core
Instead of patching all the various wizards and provisioners to send back the id of the new account, I'll rather patch onAddAccount(), AddMailAccount(), AddIMAccount() to store the current list of accounts, then call the wizards and then see which ID is new and then select it. A bit hacky but the wizards are too ugly to touch them.
Duplicate of this bug: 35805
Attached patch 679873.patchSplinter Review

Would this work for you?

Attachment #9077858 - Flags: feedback?(neil)
Attachment #9077858 - Flags: feedback?(ben.bucksch)
Status: NEW → ASSIGNED
Type: defect → enhancement
Attachment #9077858 - Flags: review?(jorgk)
Attachment #9077858 - Flags: review?(iann_bugzilla)
Comment on attachment 9077858 [details] [diff] [review]
679873.patch

Looks OK to me, but I'm not an expert in the field.
Attachment #9077858 - Flags: review?(jorgk) → review+
Comment on attachment 9077858 [details] [diff] [review]
679873.patch

Tested with creating IMAP, rss and news accounts and didn't hit any issues.
LGTM r=me
Attachment #9077858 - Flags: review?(iann_bugzilla) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/41829078a11a
Select newly created server in the account manager. r=jorgk,IanN

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 71.0
You need to log in before you can comment on or make changes to this bug.