progress meter on linux doesn't stop spinning

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
18 years ago
7 years ago

People

(Reporter: blizzard, Assigned: blizzard)

Tracking

({perf})

Trunk
mozilla0.9.3
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
Build is 2001 02 07 11.  If I'm in the message window and I hit delete and the
status bar is spinning telling me it's doing something sometimes I have to move
the mouse before the status bar will stop spinning.  It doesn't happen every
time but it does happen very often.
(Assignee)

Updated

18 years ago
Whiteboard: critical for mozilla 0.8
thanks for the bug, blizzard.  we know of a few problems already with status /
meteors not stopping.  we're investigating.

Comment 2

18 years ago
Created attachment 24670 [details] [diff] [review]
proposed fix

Comment 3

18 years ago
blizzard, could you try the attached patch, if you have a build tree, that is.
sr=sspitzer on the fix. 

it fixes the problems I was seeing with meteors not stopping with my pop account.

over to bienvenu
Assignee: sspitzer → bienvenu
(Assignee)

Comment 5

18 years ago
It doesn't seem to help here.

Comment 6

18 years ago
Scott, could you give a yay or nay on the patch too?

Comment 7

18 years ago
yay!

=)

I still can't seem to reproduce these problems though. blizard is this with your
imap account?
(Assignee)

Comment 8

18 years ago
Yes, this an imap account.

Comment 9

18 years ago
pop accounts here
Keywords: perf
QA Contact: esther → stephend
Summary: status bar never stops spinning → progress meter never stops spinning

Comment 10

18 years ago
Chris, the problem you're seeing looks to me like linux is not processing the
event that fires the timer unless you move the mouse. The problem I fixed is
that the meteors *never* stop no matter how much you move the mouse.
Looks like a perfect milestone freeze fix (almost perfect -- could be one line
instead of two :-).  brendan-for-drivers@mozilla.org says get this in.

/be
but (as Asa said via email) please leave the bug open, targeted at 0.9, for
investigation of blizzard's linux/timer/??? probs.

/be

Comment 13

18 years ago
I'll definitely leave it open - in fact, I'll need to reassign it to someone who
has a clue about linux event handling. Any suggestions? Is it really possible
that a js timer would not fire until a mouse event is triggered?
anything's possible, but js timeouts aren't supposed to depend on mouse motion.
Who knows mailnews code and Linux timer impl?

/be

Comment 15

18 years ago
moving to .9 and clearing status whiteboard.
Whiteboard: critical for mozilla 0.8
Target Milestone: --- → mozilla0.9

Comment 16

18 years ago
Maybe wrong, but this reminds me of timer related bug 35284 & Co. (34871 and
43789) CC Pavlov, in case he has an idea.
(Assignee)

Comment 17

18 years ago
I know timers.  Can you tell me where that particular timer is added and what
its callback is?  I can look into this.

Comment 18

18 years ago
mailwindow.js

look for a stopTimerID = setTimeout("something._stopMeteoers", 500);
Summary: progress meter never stops spinning → progress meter on linux doesn't stop spinning

Comment 19

18 years ago
blizzard, do you want to take this bug?
(Assignee)

Comment 20

18 years ago
Not really.  I'm still not sure what's causing it.  Tell you what, assign it to
me I'll play with the timer and see if I can track it down and maybe I can can
give you more information.

Comment 21

18 years ago
reassigning to blizzard.
Assignee: bienvenu → blizzard
(Assignee)

Comment 22

18 years ago
I wonder if this is related to bug 66457.

Comment 23

18 years ago
*** Bug 73617 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 24

17 years ago
Please see bug 79910 i submitted
It is really annoying that the progress meter does not stop. It halts
downloading of mail. If that bar keeps spinning after downloading mails, it WONT
download new mail unless it's stopped first. How to stop it? By moving the mouse
inside the mail window
This bug is currently the most annoying one to me.
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 25

17 years ago
This bug depends on  bug 79910 i mentioned earlier. Same behaviour

(Assignee)

Comment 26

17 years ago
I haven't seen this problem in a while.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
If anybody still sees this (as blizzard has filed originally), please do
re-open.  But, I can't reproduce this anymore myself with:

RedHat Linux 7.1 with Gnome - 2001-08-14-12, using Classic & Modern on both
POP3, IMAP, and local folders.  If there are other issues related, but not
specifically as filed, but open a new bug.  Thanks.

Verified FIXED.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.