not prompted to send as Plain Text | HTML | Both

VERIFIED FIXED in mozilla0.8

Status

--
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: asa, Assigned: bugzilla)

Tracking

({regression})

Trunk
mozilla0.8
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: critical for mozilla 0.8)

(Reporter)

Description

18 years ago
Tested this morning's Mac and win32 builds. 020704

When sending a mail message with HTML content the user is not prompted for send
as type options.

1. compose new message
2. add a table or HR or some other HTML
3. send message

results: not prompted to send as plain text, html or both
expecrted: prompted.
(Reporter)

Comment 1

18 years ago
adding keywords, setting severity.
Severity: normal → major
Keywords: mozilla0.8, regression
Whiteboard: critical for mozilla 0.8

Comment 2

18 years ago
This is even worse. All emails are being sent as HTML even with "Convert the
message to plain text" setting on. I am sure this is the same bug therefore I do
not report it as a new one. However does this  mean that the title of the bug
should be changed? 

Seen on both Win32 2001020606 and 2001020704 installer builds (Windows ME).
(Assignee)

Comment 3

18 years ago
I am looking at it... seems to be something wrong in JS: The backend correctly
build the list of user that doesn't support HTML but JS see this string as empty!!!
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.8
(Reporter)

Comment 4

18 years ago
*** Bug 67980 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

18 years ago
*** Bug 67980 has been marked as a duplicate of this bug. ***
*** Bug 67980 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

18 years ago
*** Bug 67980 has been marked as a duplicate of this bug. ***

Updated

18 years ago
QA Contact: esther → sheelar
(Assignee)

Comment 8

18 years ago
Here is the fix:

Index: MsgComposeCommands.js
===================================================================
RCS file:
/cvsroot/mozilla/mailnews/compose/resources/content/MsgComposeCommands.js,v
retrieving revision 1.143
diff -w -u -4 -r1.143 MsgComposeCommands.js
--- MsgComposeCommands.js	2001/02/05 07:53:02	1.143
+++ MsgComposeCommands.js	2001/02/07 22:13:00
@@ -1623,15 +1623,17 @@
     if (sendFormat == msgCompSendFormat.AskUser)
     {
         //Well, before we ask, see if we can figure out what to do for ourselves
         
-        var noHtmlRecipients = new String("");
+        var noHtmlRecipients;
         var noHtmlnewsgroups;
         var preferFormat;
 
         //Check the address book for the HTML property for each recipient
         try {
-            preferFormat = msgCompose.CheckAndPopulateRecipients(true, true,
noHtmlRecipients);
+            var obj = new Object;
+            preferFormat = msgCompose.CheckAndPopulateRecipients(true, true, obj);
+            noHtmlRecipients = obj.value;
         } catch(ex)
         {
             var msgCompFields = msgCompose.compFields;
             noHtmlRecipients = msgCompFields.GetTo() + "," +
msgCompFields.GetCc() + "," + msgCompFields.GetBcc();

Comment 9

18 years ago
sr=mscott
(Reporter)

Comment 11

18 years ago
please check this in.  thanks!  a=asa and all that.
(Assignee)

Comment 12

18 years ago
Fixed and checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

18 years ago
*** Bug 67931 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
commercial trunk buildid:  2001021909 win98
                           2001021904 mac
                           2001021908 linux

verified 
Status: RESOLVED → VERIFIED

Updated

18 years ago
Keywords: mozilla0.8
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.