wrong characters in signature (TXT file signature other than utf-8 is garbled after Thunderbird 6 on Mac)

RESOLVED DUPLICATE of bug 680320

Status

RESOLVED DUPLICATE of bug 680320
7 years ago
7 years ago

People

(Reporter: jorgevismara, Unassigned)

Tracking

6 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 553985 [details]
my signature file

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/15.0.849.1 Safari/535.1

Steps to reproduce:

Thunderbird 6 error... signature file mis-read 

I have had a signature file for years. it has a couple of symbols. 
after I upgraded to Thunderbird 6.0 the symbols are read/imported/converted incorrectly. 
but the symbols in sent messages are correct. 
here a sample: 

>> 
>> 
> -- 
>  Keep smiling ! 
> ° Jorge Vismara 
> ° www.JorgeVismaraBooks.net 
> ° www.JorgeVismara.net - digitally captured emotions 
> ° www.Pelourinho.com - 15 years online ! ! ! 
> 
> • If voting could really change things, It would be illegal. 
-- 
ð Keep smiling ! 
¡ Jorge Vismara 
¡ www.JorgeVismaraBooks.net 
¡ www.JorgeVismara.net - digitally captured emotions 
¡ www.Pelourinho.com - 15 years online ! ! ! 

¥ If voting could really change things, It would be illegal.


Actual results:

the characters of the TXT signature file are wrongly interpreted/converted.


Expected results:

instead of 

-- 
ð Keep smiling ! 
¡ Jorge Vismara 
¡ www.JorgeVismaraBooks.net 
¡ www.JorgeVismara.net - digitally captured emotions 
¡ www.Pelourinho.com - 15 years online ! ! ! 

¥ If voting could really change things, It would be illegal.

I should see:
-- 
 Keep smiling ! 
° Jorge Vismara 
° www.JorgeVismaraBooks.net 
° www.JorgeVismara.net - digitally captured emotions 
° www.Pelourinho.com - 15 years online ! ! ! 

• If voting could really change things, It would be illegal.
New problem from Tb 6?
Which charset do you use as charset of signature text?
Can sinature in utf-8 be a workaround?
Same problem as mail&news core bug 680320?
(Reporter)

Comment 2

7 years ago
Good question about the charset... I never care about it, as I never had a problem for many many upgrades I've done in the Mac (move out of Windows 4 years ago).
If I open the TXT file in TextWrangler (a common text editor of Mac machines) the chars look fine.
If I open the TXT in Word, it looks weird, but different from T 6 interpretation... 
so here I go trying to figure out this charset mistery... 
thanks for the light...
(Reporter)

Comment 3

7 years ago
Thanks Wada...
that did the trick... even though TextWrangler was set to the utf-8 by default, it only uses the code when creating NEW files.  
after a bit of tweaking I was able to restore my readable signature in T 6...
still the question remains, why this signature was perfect in all other versions of Thunderbird except this one...?
thanks again...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Summary: wrong characters in signature → wrong characters in signature (TXT file signature other than utf-8 is garbled after Thunderbird 6 on Mac)
Duplicate of bug: 680320
You need to log in before you can comment on or make changes to this bug.