Error: uncaught exception: [Exception... "prompt aborted by user" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource:///components/nsPrompter.js :: openTabPrompt :: line 462" data: no]

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
4 years ago

People

(Reporter: lnagpal, Unassigned)

Tracking

6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

i called  the webservice using  jquery,i got this erroe
This will happen when the prompt is cancelled.

If you're seeing this under other scenarios, we need more information.  What is "the webservice"?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
when i called the webserive method  using ajax method in jquery,though it was called but while returning the value it shows prompt error in Mozilla.
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #1)

> This will happen when the prompt is cancelled.
> 
> If you're seeing this under other scenarios, we need more information.  What
> is "the webservice"?

Comment 3

7 years ago
This bug occurs because Firefox repeats the same JavaScript function twice in a situation where it should not be. I.E:

<SCRIPT type="text/javascript">
	if ($row1['available'] == 'no') {
		echo '
			alert ("1 is no longer available.");
			document.getElementById("submit").click();
		';
	}
	if ($row2['available'] == 'no') {
		echo '
			alert ("2 is no longer available.");
			document.getElementById("submit").click();
		';
	}
	if ($row3['available'] == 'no') {
		echo '
			alert ("3 is no longer available.");
			document.getElementById("submit").click();
		';
	}
</SCRIPT>

Where "document.getElementById("submit").click();" will toggle a form submit button.

If both size2 and size3 are unavailable, Firefox's JavaScript engine will execute click() for size2, navigate to the form target, but then parse click() for size3.
This is where the problem occurs.

Firefox must be reprogrammed to halt the parsing of additional identical click()'s when click() is used with something either navigates away or navigates away via a form (I have not determined if it will matter).

This bug is present in Firefox 10.0 (10.0+build1-0ubuntu0.10.04.2)

Comment 4

7 years ago
Sorry, in my previous post I did a lowzy conversion of my own code into a neutral example. When I said "size", I should have said "row":

"If both size2 and size3 are unavailable" > 'If both row2 and row3 are unavailable'

Its been a long day.

Comment 5

7 years ago
I've completely botched my posts. I just noticed I forgot to convert my PHP into something that would make sense.

If you still can't understand my gist then e-mail me and I'll reply on a better day.

Sorry guys.

Comment 6

4 years ago
I am having a similar problem.

Firefox 38.0a2 (2015-03-30) I get an error "uncaught exception: out of memory" (unlikely, I have a lot of memory and donot touch the swap I have, which is a lot also)

On Firefox 35.0.1 I get: "NS_ERROR_NOT_AVAILABLE: prompt aborted by user"

On the 38.0a2 there is a user dialog that flashes by so fast I cannot read it.

I am not going to take the time to produce a reproducable example unless some one asks (and I will after Easter if asked) but I can make the problem go away:

The code that is problematic is called by a 'click' event on a button.  If i put the button and the associalted 2 input elements (one type='text' one type = '[assword') I get this error.  If I take away the form I do not.

Ask me and I will produce a reproducable example.
You need to log in before you can comment on or make changes to this bug.