Closed Bug 680038 Opened 9 years ago Closed 9 years ago

When Firefox is unresponsive because a page is loading, save the keystrokes

Categories

(Firefox :: General, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 516518

People

(Reporter: nicolas.barbulesco, Unassigned)

Details

Hello,

See discussion here : bug 677090.

Windows Vista. Firefox 4.0.1.

So, a page is loading, and too bad ! Firefox is not responding. I cannot scroll in another tab, which is already loaded.

I encounter that too with Google Chrome on Windows Vista.

With Google Chrome in this situation :

I was in a form field or in the address bar. I type some characters. They don't appear at once. But they are saved. And when Google Chrome becomes responsive again, the characters are inserted.

With Firefox in this situation :

I was in a form field or in the address bar. I type some characters. They don't appear at once. And they are lost. And when Firefox becomes responsive again, the characters are not inserted. This is annoying.

In this situation, please make Firefox save the keystrokes.

Thanks,

Nicolas
Again, that will be solved by the Electrolysis project (using multiple processes). The browser is not capable of buffering keystrokes in this situation (that's why you say it is not responding !). Using multiple threads or processes is the solution.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: electrolysis
Blocks: useragent
No longer blocks: useragent
You need to log in before you can comment on or make changes to this bug.