Last Comment Bug 680044 - Closing the script debugger UI does not disable the debugger
: Closing the script debugger UI does not disable the debugger
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: minotaur
  Show dependency treegraph
 
Reported: 2011-08-18 04:04 PDT by Panos Astithas [:past]
Modified: 2011-09-23 01:48 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Panos Astithas [:past] 2011-08-18 04:04:43 PDT
Clicking on the debugger's close button causes the removal of the TabClose listener, before it gets a chance to run in order to disable the debugger. This should be causing memory leaks, but since there are already leaks present in the browser mochitests, I can't be sure. We definitely have to fix the cleanup sequence though.
Comment 1 Panos Astithas [:past] 2011-09-21 09:15:16 PDT
This was fixed in:

https://hg.mozilla.org/users/dcamp_campd.org/remote-debug/rev/8b07c3ebb8d4

I couldn't see any reduction in memory leaks, so I'm leaving the bug open in order to investigate it some more.
Comment 2 Panos Astithas [:past] 2011-09-23 01:48:49 PDT
I filed bug 688705 to track the leaks, since it doesn't seem likely that they are related to this issue.

Note You need to log in before you can comment on or make changes to this bug.