Last Comment Bug 680113 - Select Add-ons dialog lists distribution add-ons as installed by the user
: Select Add-ons dialog lists distribution add-ons as installed by the user
Status: VERIFIED FIXED
[qa!]
: verified-aurora, verified-beta
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla9
Assigned To: Justin Wood (:Callek)
:
Mentors:
Depends on:
Blocks: 596343
  Show dependency treegraph
 
Reported: 2011-08-18 09:03 PDT by :Ehsan Akhgari (away Aug 1-5)
Modified: 2011-11-03 09:47 PDT (History)
14 users (show)
hskupin: in‑testsuite+
hskupin: in‑litmus?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Screenshot (79.75 KB, image/png)
2011-08-18 09:03 PDT, :Ehsan Akhgari (away Aug 1-5)
no flags Details
WIP 1 (3.53 KB, patch)
2011-09-03 23:30 PDT, Justin Wood (:Callek)
no flags Details | Diff | Splinter Review
trunk patch (no new test) (10.34 KB, patch)
2011-09-05 18:47 PDT, Justin Wood (:Callek)
bugspam.Callek: review-
faaborg: ui‑review-
Details | Diff | Splinter Review
trunk patch v2 (13.43 KB, patch)
2011-09-08 01:14 PDT, Justin Wood (:Callek)
dtownsend: review+
Details | Diff | Splinter Review
aurora patch v1 (8.43 KB, patch)
2011-09-08 02:20 PDT, Justin Wood (:Callek)
no flags Details | Diff | Splinter Review
aurora patch v1.1 (11.56 KB, patch)
2011-09-08 05:14 PDT, Justin Wood (:Callek)
no flags Details | Diff | Splinter Review
trunk test (2.37 KB, patch)
2011-09-12 22:18 PDT, Justin Wood (:Callek)
bmcbride: review+
Details | Diff | Splinter Review
aurora patch v2 (13.85 KB, patch)
2011-09-12 22:23 PDT, Justin Wood (:Callek)
bmcbride: review+
Details | Diff | Splinter Review
aurora patch v2.1 (13.89 KB, patch)
2011-09-14 03:39 PDT, Justin Wood (:Callek)
bugspam.Callek: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
screenshot (45.26 KB, image/png)
2011-10-11 04:40 PDT, Vlad [QA]
no flags Details

Description :Ehsan Akhgari (away Aug 1-5) 2011-08-18 09:03:11 PDT
Created attachment 554105 [details]
Screenshot

I think that I got Test Pilot because I run Nightly, but addon manager tells me that I have installed it.
Comment 1 Dave Townsend [:mossop] 2011-08-18 10:34:13 PDT
We should be able to spot these based on the pref we set when they get installed, it won't be perfect at this point though. If this was just Feedback I wouldn't be too concerned about fixing this for 8, but Seamonkey has distribution add-ons that they install with releases
Comment 2 Justin Wood (:Callek) 2011-08-20 10:47:38 PDT
(In reply to Dave Townsend (:Mossop) from comment #1)
> We should be able to spot these based on the pref we set when they get
> installed, it won't be perfect at this point though. If this was just
> Feedback I wouldn't be too concerned about fixing this for 8, but Seamonkey
> has distribution add-ons that they install with releases

In your mind, what is the best course, UX wise for this.

For both Aurora (8) and Trunk if different (since Aurora is string frozen of course). I might be willing to look into this, but I can't promise anything without a course of action to address.
Comment 3 Dave Townsend [:mossop] 2011-08-23 12:20:56 PDT
(In reply to Justin Wood (:Callek) from comment #2)
> (In reply to Dave Townsend (:Mossop) from comment #1)
> > We should be able to spot these based on the pref we set when they get
> > installed, it won't be perfect at this point though. If this was just
> > Feedback I wouldn't be too concerned about fixing this for 8, but Seamonkey
> > has distribution add-ons that they install with releases
> 
> In your mind, what is the best course, UX wise for this.
> 
> For both Aurora (8) and Trunk if different (since Aurora is string frozen of
> course). I might be willing to look into this, but I can't promise anything
> without a course of action to address.

Would like to get faaborg's input here but my thinking is that these add-ons were essentially installed by the application and so should really fall under the same section as the other app-shipped add-ons. That I think means we don't incur any l10n cost so we can just do the same thing on trunk and aurora.
Comment 4 Alex Faaborg [:faaborg] (Firefox UX) 2011-08-23 13:10:49 PDT
Yeah, I'm basically trying to create two groups:

-add-ons that were very specifically installed by the user, individually, from AMO, because they wanted them
-everything else

There may indeed be add-ons that the user wants in the second category, but that's why we are asking, because they also want Firefox to have fantastic performance.
Comment 5 Alex Faaborg [:faaborg] (Firefox UX) 2011-08-23 15:57:44 PDT
The string of "Bundled with &brandShortname" is fine.

Also just listing user incorrectly isn't that big of a deal (you could I guess make an argument that since they downloaded the browser bundled with stuff they kind of installed it themselves, but anyway).
Comment 6 Alex Faaborg [:faaborg] (Firefox UX) 2011-08-23 17:42:31 PDT
From a long discussion on IRC I would like to change this over to

"You (Bundled with &brandShortname)"

So the overall distinction of "third party" v "you" remains intact (comment #4), but we also make it clear why we believe that you installed this extension (comment #0).
Comment 7 Alex Faaborg [:faaborg] (Firefox UX) 2011-08-23 17:44:15 PDT
Also note that at no point should we ever say just &brandShortname in this column, I believe there are some cases where we are currently doing that.  Follow up bug, we should switch that over to just "You" for Aurora, since ultimately it was the user, that installed the extension (selected a particular bundled package, etc.)
Comment 8 Justin Wood (:Callek) 2011-08-23 17:46:36 PDT
(In reply to Dave Townsend (:Mossop) from comment #1)
> We should be able to spot these based on the pref we set when they get
> installed, it won't be perfect at this point though. If this was just
> Feedback I wouldn't be too concerned about fixing this for 8, but Seamonkey
> has distribution add-ons that they install with releases

(In reply to Alex Faaborg [:faaborg] (Firefox UX) from comment #6)
> From a long discussion on IRC I would like to change this over to
> 
> "You (Bundled with &brandShortname)"
> 
> So the overall distinction of "third party" v "you" remains intact (comment
> #4), but we also make it clear why we believe that you installed this
> extension (comment #0).

Ok, after discussing with faabord on IRC, as he just mentioned. My plan here is:

Fix this for SeaMonkey with ifdefs, on aurora in the way we discussed on IRC.
Do a trunk patch, that is almost the same with "You (Bundled with &brandShortname)"

Only test on trunk, due to the fact that it will be ifdef'ed out for Firefox, and SeaMonkey's test story stinks right now.

This preserves faaborg's desire to only have the two options, and gives an indication to the user how it got installed, more directly.
Comment 9 Dave Townsend [:mossop] 2011-08-23 18:14:47 PDT
(In reply to Justin Wood (:Callek) from comment #8)
> (In reply to Dave Townsend (:Mossop) from comment #1)
> > We should be able to spot these based on the pref we set when they get
> > installed, it won't be perfect at this point though. If this was just
> > Feedback I wouldn't be too concerned about fixing this for 8, but Seamonkey
> > has distribution add-ons that they install with releases
> 
> (In reply to Alex Faaborg [:faaborg] (Firefox UX) from comment #6)
> > From a long discussion on IRC I would like to change this over to
> > 
> > "You (Bundled with &brandShortname)"
> > 
> > So the overall distinction of "third party" v "you" remains intact (comment
> > #4), but we also make it clear why we believe that you installed this
> > extension (comment #0).
> 
> Ok, after discussing with faabord on IRC, as he just mentioned. My plan here
> is:
> 
> Fix this for SeaMonkey with ifdefs, on aurora in the way we discussed on IRC.
> Do a trunk patch, that is almost the same with "You (Bundled with
> &brandShortname)"

I have concerns over the length of this string making the other columns too small, but I guess since this case is likely to be rare we could just live with it wrapping.
Comment 10 Justin Wood (:Callek) 2011-08-23 19:03:58 PDT
(In reply to Dave Townsend (:Mossop) from comment #9)
> I have concerns over the length of this string making the other columns too
> small, but I guess since this case is likely to be rare we could just live
> with it wrapping.

I have the same concern, and its much more likely for SeaMonkey users, so if you and faaborg can throw together a better string, I'm more than happy to have it.
Comment 11 Justin Wood (:Callek) 2011-09-03 23:30:02 PDT
Created attachment 558123 [details] [diff] [review]
WIP 1

This is my WIP (against trunk) of where I am headed with my code here. This does not yet change any strings, and keeps the three separate groups.

In a brief test on SeaMonkey this seemed to do as expected, waiting on a basic try run, and then will go from there. Feel free to provide early feedback.
Comment 12 Justin Wood (:Callek) 2011-09-05 18:47:14 PDT
Created attachment 558364 [details] [diff] [review]
trunk patch (no new test)

This is the patch I have so far for trunk, about to push to try. This does not yet implement a test for this functionality.

Branch patch should be very similar.
Comment 13 Justin Wood (:Callek) 2011-09-06 05:34:44 PDT
Comment on attachment 558364 [details] [diff] [review]
trunk patch (no new test)

Try bit me in the behind for this test change, rest of code changes should be fine though. (I'm commenting the following here so I can fix this [easier] on the other computer when I get to it after today's releases):

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 38, expected 42
/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 39, expected 43
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 40, expected 44
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 41, expected 45
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 42, expected 46
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 43, expected 47
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 44, expected 48
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 45, expected 49
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 46, expected 50
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 47, expected 51
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 48, expected 52
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 49, expected 38
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 50, expected 39
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 51, expected 40
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have been in the right position - Got 52, expected 41
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_select_selection.js | Should have seen the right number of add-ons - Got 60, expected 90
Comment 14 Alex Faaborg [:faaborg] (Firefox UX) 2011-09-06 16:59:06 PDT
Comment on attachment 558364 [details] [diff] [review]
trunk patch (no new test)

The string we want here is:

"You (Bundled)"

where there is no reference to brandShortName.  The rational is that the installation of the browser and distributed add-ons was intentionally and actively done by the user (you), and not the browser.
Comment 15 Justin Wood (:Callek) 2011-09-08 01:14:59 PDT
Created attachment 559073 [details] [diff] [review]
trunk patch v2

After sitting and thinking about this, since we're only doing a new string type here, do you want/need a test for this.

If so:
 * what specifically about this should I test?
 * Is it worth writing a new test, or extending browser_select_selection.js?
Comment 16 Justin Wood (:Callek) 2011-09-08 02:20:38 PDT
Created attachment 559080 [details] [diff] [review]
aurora patch v1

This is the aurora patch. (requesting ui-r for clarity)

Firefox Changes:
* No longer specifies "Firefox" in any type of install.
* Specifies "You" for Application level extensions
* No longer groups Application level extensions separate from profile ones.
* No-op function and Services.jsm use (kept out of ifdefs for clarity of code)

SeaMonkey Changes:
* Specifies "SeaMonkey" for both application installs and distributed installs.
* No longer groups Application/Distro level extensions separately of profile.
* XBL API change, to use the isDistroInstalled function, as in the trunk patch.

All these files are preprocessed and MOZ_SUITE is defined in this scope for SeaMonkey.
Comment 17 Justin Wood (:Callek) 2011-09-08 05:14:33 PDT
Created attachment 559113 [details] [diff] [review]
aurora patch v1.1

in v1 of the aurora patch, I forgot to qref....
Comment 18 Dave Townsend [:mossop] 2011-09-09 14:26:38 PDT
Comment on attachment 559073 [details] [diff] [review]
trunk patch v2

Review of attachment 559073 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, still want to see the addition of testing the source string in the UI test though

::: toolkit/locales/en-US/chrome/mozapps/extensions/selectAddons.properties
@@ +1,4 @@
>  #LOCALIZATION NOTE (source.profile) add-ons installed by the user, this may be
>  # translated as "You" or "User" depending on the locale
>  source.profile=You
> +#LOCALIZATION NOTE (source.profile) add-ons shipped with the application, and thus

You have the name wrong there
Comment 19 Dave Townsend [:mossop] 2011-09-09 14:32:24 PDT
Comment on attachment 559113 [details] [diff] [review]
aurora patch v1.1

Review of attachment 559113 [details] [diff] [review]:
-----------------------------------------------------------------

This works I guess, I wonder though, why not just use exactly the trunk patch but don't add the new string and use source.profile for the app/bundled cases? The less difference between the two patches the better I think.

::: toolkit/mozapps/extensions/content/selectAddons.xml
@@ +133,5 @@
> +            case AddonManager.SCOPE_APPLICATION:
> +#ifdef MOZ_SUITE
> +              this._keep.checked = !aAddon.userDisabled;
> +              this.setAttribute("source", this._appStrings.getString("brandShortName"));
> +              break; // Fall through on else, on purpose.

Change this to say "Fall through for other applications, on purpose
Comment 20 Justin Wood (:Callek) 2011-09-09 15:02:26 PDT
(In reply to Dave Townsend (:Mossop) from comment #19)
> Comment on attachment 559113 [details] [diff] [review]
> aurora patch v1.1

> This works I guess, I wonder though, why not just use exactly the trunk
> patch but don't add the new string and use source.profile for the
> app/bundled cases? The less difference between the two patches the better I
> think.

My reasoning was to avoid API churn, but if you want the trunk patch basically I'll fix it to be that.
Comment 21 Dave Townsend [:mossop] 2011-09-09 15:05:41 PDT
(In reply to Justin Wood (:Callek) from comment #20)
> (In reply to Dave Townsend (:Mossop) from comment #19)
> > Comment on attachment 559113 [details] [diff] [review]
> > aurora patch v1.1
> 
> > This works I guess, I wonder though, why not just use exactly the trunk
> > patch but don't add the new string and use source.profile for the
> > app/bundled cases? The less difference between the two patches the better I
> > think.
> 
> My reasoning was to avoid API churn, but if you want the trunk patch
> basically I'll fix it to be that.

There is very little change here and what change there is is necessary for partner repacks so I'd rather do that than have a big difference between the branches
Comment 22 Dave Townsend [:mossop] 2011-09-09 18:05:16 PDT
Comment on attachment 559113 [details] [diff] [review]
aurora patch v1.1

Waiting for updates per the discussion on IRC
Comment 23 Justin Wood (:Callek) 2011-09-09 22:52:59 PDT
Landed m-c patch on m-i (and accidentally on m-c) which had to be backed out due to my tested version of the test patch getting lost somehow.

Re-Landed as http://hg.mozilla.org/integration/mozilla-inbound/rev/9ac6e2dfaf1e
Comment 24 Matt Brubeck (:mbrubeck) 2011-09-11 06:38:38 PDT
http://hg.mozilla.org/mozilla-central/rev/9ac6e2dfaf1e
Comment 25 Justin Wood (:Callek) 2011-09-12 22:18:17 PDT
Created attachment 559931 [details] [diff] [review]
trunk test

(not pushed through try yet)
Comment 26 Justin Wood (:Callek) 2011-09-12 22:23:15 PDT
Created attachment 559932 [details] [diff] [review]
aurora patch v2

This patch addresses Mossops review comments, folds in the test changes from trunk (except new string)

I am aware this test will fail in SeaMonkey, but our branch test story isn't happy at the moment, so that is ok.
Comment 27 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-09-12 23:50:31 PDT
Comment on attachment 559931 [details] [diff] [review]
trunk test

Review of attachment 559931 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/extensions/test/browser/browser_select_selection.js
@@ +77,5 @@
> +    return "";
> +
> +  var strings = Services.strings.createBundle("chrome://mozapps/locale/extensions/selectAddons.properties");
> +  switch (aSource) {
> +    case AddonManager.SCOPE_APPLICATION:

Nit: Should probably replace this with APP, and SCOPE_PROFILE below with PROFILE. Mixing them makes confusion.
Comment 28 Blair McBride [:Unfocused] (UNAVAILABLE) 2011-09-13 00:06:59 PDT
Comment on attachment 559932 [details] [diff] [review]
aurora patch v2

Review of attachment 559932 [details] [diff] [review]:
-----------------------------------------------------------------

Yay for interdiff!

Just needs some comment fixes.

The SeaMonkey test situation is... unfortunate.

::: toolkit/mozapps/extensions/content/selectAddons.xml
@@ +127,5 @@
> +
> +          switch (scope) {
> +            case AddonManager.SCOPE_APPLICATION:
> +#ifdef MOZ_SUITE
> +              this.setAttribute("source", this._appStrings.getString("brandShortName"));

Feels like this deserves a comment explaining it. A simple "Suite uses brandShortName on this branch due to a string freeze" would suffice.

::: toolkit/mozapps/extensions/test/browser/browser_select_selection.js
@@ +78,5 @@
> +
> +  var strings = Services.strings.createBundle("chrome://mozapps/locale/extensions/selectAddons.properties");
> +  switch (aSource) {
> +    case AddonManager.SCOPE_APPLICATION:
> +      // Fall through, aurora did not change ths string here

"aurora" here will become not-useful in a few short weeks. Maybe "this branch"? Would be useful to reference the reason too ("due to string freeze", or something).

Also, typo. s/ths/this/
Comment 30 Justin Wood (:Callek) 2011-09-14 03:39:59 PDT
Created attachment 560132 [details] [diff] [review]
aurora patch v2.1

Address review comments, requesting approval for this change for aurora.

It incorporates stuff faaborg wanted for UX, and fixes some UX concerns the SeaMonkey team had.
Comment 31 Matt Brubeck (:mbrubeck) 2011-09-14 06:49:04 PDT
Test and followup landed on trunk:
https://hg.mozilla.org/mozilla-central/rev/20d65201c7ff
https://hg.mozilla.org/mozilla-central/rev/0159e317b735
Comment 32 Asa Dotzler [:asa] 2011-09-22 14:28:36 PDT
Comment on attachment 560132 [details] [diff] [review]
aurora patch v2.1

Really late but this is a high profile feature we're introducing. Please get this landed ASAP. We really really do not want to take this later in beta.
Comment 33 Justin Wood (:Callek) 2011-10-01 18:02:17 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/3e508f45597c
I landed this on aurora and forgot to update bug (sorry)
Comment 34 Vlad [QA] 2011-10-11 04:40:54 PDT
Created attachment 566170 [details]
screenshot

Hi guys.
I have just updated Firefox beta from 7b6 to 8b2 on the betatest channel and the add-on manager is saying that I have installed the feedback addon.
Is this intended?
How can I test this on Aurora and Nightly? If I try to update from an early aurora build to the latest one or use the same profile in aurora and nightly, no window with addons appears in this format (see screenshot).I get the old format. The same applies to Nightly.
Comment 35 Henrik Skupin (:whimboo) 2011-10-11 05:54:45 PDT
(In reply to Vlad [QA] from comment #34)
> I have just updated Firefox beta from 7b6 to 8b2 on the betatest channel and
> the add-on manager is saying that I have installed the feedback addon.
> Is this intended?

The feedback extension is a distribution add-on which is part of Firefox Beta and gets installed into your profile. So yes, that's expected.

> How can I test this on Aurora and Nightly? If I try to update from an early
> aurora build to the latest one or use the same profile in aurora and
> nightly, no window with addons appears in this format (see screenshot).I get
> the old format. The same applies to Nightly.

You have to test this with different Aurora versions. Means, if you want to test it for Aurora 9.0a2 you will have to install an Aurora 8.0a2 build first. Setting the preference to false and performing an update has to show the add-on selection dialog. It only gets shown when there is a version bump between versions. Same applies to Nightly builds.
Comment 36 Vlad [QA] 2011-10-12 04:59:36 PDT
> You have to test this with different Aurora versions. Means, if you want to
> test it for Aurora 9.0a2 you will have to install an Aurora 8.0a2 build
> first. Setting the preference to false and performing an update has to show
> the add-on selection dialog. It only gets shown when there is a version bump
> between versions. Same applies to Nightly builds.

I did just that but the add-ons window doesn't appear. Can you please tell me what preference have I set to false in order for that window to appear when upgrading from an older build to the latest one.
Thanks
Comment 37 Henrik Skupin (:whimboo) 2011-10-12 07:47:49 PDT
The same you have used to verify some other bugs: 'extensions.shownSelectionUI'. Simple reset it, if it has been set.
Comment 38 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-10-13 10:54:15 PDT
qa+ for verification in Firefox 8.
Comment 39 Vlad [QA] 2011-10-28 02:43:28 PDT
Hi guys.
Can you please provide an application that is installing a 3rd party addon?
I want to verify this bug but I could't find one.
Thanks
Comment 40 Dave Townsend [:mossop] 2011-10-28 09:20:56 PDT
(In reply to Vlad [QA] from comment #39)
> Hi guys.
> Can you please provide an application that is installing a 3rd party addon?
> I want to verify this bug but I could't find one.
> Thanks

Skype installs a third party add-on
Comment 41 Vlad [QA] 2011-11-03 08:58:53 PDT
Setting resolution to Verified Fixed on 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20100101 Firefox/8.0 beta 6 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20111103 Firefox/9.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a1) Gecko/20111103 Firefox/10.0a1

I have made an update from 7b6 to 8b6 on releasetest channel and the addon was listed as "you" like in comment16. The add-on is disabled as expected. I repeated the same steps on Aurora(8.0a2 to 9.0a2) and Nightly (9.0a1 to 10.0a1) and everything worked as expected.
Comment 42 Henrik Skupin (:whimboo) 2011-11-03 09:47:37 PDT
What's our testing strategy here? Do we need manual tests or do the automated tests cover everything?

Note You need to log in before you can comment on or make changes to this bug.