Tabs overlap Firefox button when reducing Windows Active Title Bar size

UNCONFIRMED
Unassigned

Status

()

Firefox
Theme
UNCONFIRMED
6 years ago
5 years ago

People

(Reporter: Jonathan Marzinke, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
Created attachment 554191 [details]
firefox_button_tabs_overlap.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110816154714

Steps to reproduce:

In Windows 7 Ultimate x64 using Aero Theme
1. Close Firefox (not maximized)
2. Right-click desktop and select "Personalize"
3. Select "Window Color" at bottom
4. Select "Advanced appearance settings..."
5. Select "Active Title Bar" in the "Item:" drop-down
6. Reduce "Size:" to 17
7. Apply/Save settings
8. Open Firefox


Actual results:

The Firefox Button is being overlapped by the tabs right below it.


Expected results:

I imagine this is a UI defect and overlap should not occur.
(Reporter)

Comment 1

6 years ago
I believe this is the same as 606301, though since that is a resolved bug, I thought it best to open a new one.
Component: General → Theme
QA Contact: general → theme
Version: 7 Branch → Trunk
Created attachment 560524 [details]
screenshot from latest nightly

Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110915 Firefox/9.0a1; build id 20110915030845

Verified on latest Nightly (with STR from description) and no overlap is observed: tab and Firefox button are adjacent but don't overlap.
The same is observed on Firefox 7 beta 5.
Reverified on latest Nightly an still cannot see the issue:
Mozilla/5.0 (Windows NT 6.1; rv:13.0a1) Gecko/20120213 Firefox/13.0a1

Jonathan, are you still able to reproduce this? How about in safe mode/clean profile?
http://support.mozilla.org/en-US/kb/Safe%20Mode 
http://support.mozilla.org/en-US/kb/Managing-profiles

Thank you!
(Reporter)

Comment 4

6 years ago
I'm using the latest 11 beta and when I run it is safe mode, I don't see anymore overlapping. Thank you for following up!
(In reply to Jonathan Marzinke from comment #4)
> I'm using the latest 11 beta and when I run it is safe mode, I don't see
> anymore overlapping. Thank you for following up!

Can you please disable your addons one by one to see which one is causing the overlap?

Thank you!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

6 years ago
Created attachment 597019 [details]
Firefox with 2px window padding
(Reporter)

Comment 7

6 years ago
Created attachment 597020 [details]
Firefox with default 4px window padding
(Reporter)

Comment 8

6 years ago
I think I just figured out the cause. I use a Win7 customization tool called Ultimate Windows Tweaker to reduce the window padding from 4px (default) to 2px.
http://www.thewindowsclub.com/ultimate-windows-tweaker-v2-a-tweak-ui-for-windows-7-vista

When I set it back to the default, the overlapping goes away (see the two newly attached images). I don't know if this is still considered a bug so I'll let you make that call. Thanks for looking into it.
Thanks Jonathan for your help.
I can see the overlap if I change the windows padding size to 0px (for 2px the button is just near the tabs). Will leave it as UNCONFIRMED for now, until someone from development takes a look over it to see if it is really a Firefox bug.
Status: RESOLVED → UNCONFIRMED
Component: Theme → General
Product: Firefox → Core
QA Contact: theme → general
Resolution: WORKSFORME → ---
Sure seems like a Firefox bug to me if the Firefox UI styles can't deal with this situation..
Component: General → Theme
Product: Core → Firefox
QA Contact: general → theme

Comment 11

5 years ago
Created attachment 644754 [details]
titlebars

Comment 12

5 years ago
Comment on attachment 644754 [details]
titlebars

I too have run into this bug. The normal behavior of windows applications is to leave a few pixels of space between the minimize/restore/close buttons and the program's own "stuff". When changing for example titlebar size or border padding size, firefox does not seem to deal with this change like other programs do, and if the change is big enough, you might get overlapping UI elements. 

Even if they do not actually overlap, it does stick out like a sore thumb when you have several windows open that all behave correctly while firefox doesn't. 

I will attach a screenshot to more easily demonstrate it. 1st program is IE9, 2nd is Firefox14.1, 3rd is mIRC and 4th is notepad. This is with border padding set to 2 and title bar size set to 18. Anything lower than this, and UI elements will start overlapping, while other programs deal with it without problems.

Comment 13

5 years ago
I'm sorry. I forgot to also mention that Firefox on my computer exhibits the same behaviour regardless of which add-ons or extensions I have enabled or disabled. I have also only used windows' own included features to change my aero appearance, no third party tools.
You need to log in before you can comment on or make changes to this bug.