Add Error Console as Sidebar Panel

NEW
Unassigned

Status

SeaMonkey
Sidebar
--
enhancement
16 years ago
9 months ago

People

(Reporter: Cormac F, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [SMOP])

(Reporter)

Description

16 years ago
It might be useful to allow the javascript debug window to be displayed as a 
sidebar panel,rather than having to select it from the menu and switch between 
two windows when debugging a page.

Comment 1

16 years ago
There is no JavaScript debugger for mozilla. You are talking about the 
JavaScript console. 

Changing bugzilla components
Component: JavaScript Debugger → Javascript Engine

Comment 2

16 years ago
...and reassigning to JS engine owner. Do you guys have a particular category 
for JS console related bugs?
Assignee: jband → rogerl

Comment 3

16 years ago
Nope. Marking NEW.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: other → All
Hardware: PC → All

Comment 4

16 years ago
Cool idea. Marking future.
Target Milestone: --- → Future

Comment 5

16 years ago
Shouldn't Summary be changed from 'Debugger' to 'Console' ? This is confusing
because a debugger is currently covered with bug 97945 with the Venkman
debugger: http://www.mozilla.org/projects/venkman/
(Reporter)

Comment 6

16 years ago
Changing Summary as per comments above.

From: [RFE] - Add JavaScript Debugger as Sidebar Panel

To: Add JavaScript Console as Sidebar Panel

Removing [RFE] - indicated by severity field
Summary: [RFE] - Add JavaScript Debugger as Sidebar Panel → Add JavaScript Console as Sidebar Panel

Comment 7

16 years ago
js console is not part of the js engine, over to xp apps.
Assignee: rogerl → pchen
Component: Javascript Engine → XP Apps
QA Contact: rginda → sairuh
sidebar
Assignee: pchen → sgehani
Component: XP Apps → Sidebar
QA Contact: sairuh → sujay

Comment 9

16 years ago
I'm not sure if the command will do it...:
sidebar.addPanel('JavaScriptConsole', 'chrome://global/content/console.xul','');

Comment 10

15 years ago
-> js console

I think this needs to be wontfix.  I don't think we should ever ship with this
panel, and we don't need bugs in bugzilla for work that should be done on
someone's own time, hosted on a webpage.
Assignee: sgehani → hewitt
Component: Sidebar → JavaScript Console
QA Contact: sujay → jrgm

Comment 11

15 years ago
I don't understand why you want this wontfix'ed.  The addressbook is available 
in the sidebar.  The bookmarks are available in the sidebar.  Why shouldn't the 
JavaScript console be available in the sidebar?

Comment 12

15 years ago
Bookmarks and address book are common end-user features that apply to a wide
percentage of the population.  A javascript console would apply to a very narrow
subset of the population and would, imo, be better presented as an add-on
available from, say, developer.netscape.com.  Many things would make great
sidebar panels but they wouldn't all be well-received by a large amount of
people; I say we stick to the ones that will, and I don't believe this fits that
profile.

Comment 13

15 years ago
Blake, I hear what your saying on the type of component this is. I could
understand your reasoning (that it should be done by a third party) if the
Console was not a part of the default Mozilla build.  It seems to me that
discriminating between standard componenets - many of which which (including the
js console) would provide value in a sidebar state - is counter productive for a
"developers" browser.

Personally, this would save a great deal of time if there was some way to enable
the js console in the sidebar.  I'm glad to see this still marked future and
would be very happy to be able to easily enable it. 

I tried the js above, but it looks like it doesn't allow you to add just any old
chrome to the sidebar.
the dom inspector can be in the sidebar.
why wouldnt the js console be available too ? you dont want it so that it wont
confuse users ? make it a pref, an hidden pref even, and voila !

Comment 15

15 years ago
This could be something for Phoenix as well.

Updated

11 years ago
Summary: Add JavaScript Console as Sidebar Panel → Add Error Console as Sidebar Panel
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
QA Contact: jrgmorrison → error-console
Target Milestone: Future → ---

Comment 16

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 17

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 20

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Updated

8 years ago
Status: UNCONFIRMED → NEW
Component: Error Console → Sidebar
QA Contact: error-console → sidebar

Comment 21

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Component: Error Console
QA Contact: sidebar → error-console

Updated

8 years ago
Status: UNCONFIRMED → NEW
Component: Error Console → Sidebar
QA Contact: error-console → sidebar

Comment 22

9 months ago
The old error console in Seamonkey will not be enhanced. Its more or less only there for convenience and in maintenance mode only.

Closing as wontfix.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX

Updated

9 months ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Whiteboard: [SMOP]

Updated

9 months ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.