Two finger horizontal scroll in lion directions are counterintuitive

RESOLVED DUPLICATE of bug 678392

Status

()

RESOLVED DUPLICATE of bug 678392
7 years ago
6 years ago

People

(Reporter: notforyourmail, Unassigned)

Tracking

9 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0a1) Gecko/20110818 Firefox/9.0a1
Build ID: 20110818030747

Steps to reproduce:

In Lion, Firefox uses 2 finger left and right scrolling to switch back and forth in history (see Bug 668953).  This is fine, but the scroll directions are opposite those used by the arrow buttons in the browser, causing confusion.


Actual results:

Swipe right, browser goes back in the history list.  Swipe left, browser goes forward (more recent).


Expected results:

The left and right arrows in the Firefox interface show that RIGHT is NEWER and LEFT is OLDER in the history list.  But the swipe directions go the opposite way.  This is counterintuitive.

Note that Safari also scrolls this way, but in safari, you are visibly *pushing* pages on and off the stack.  The direction makes sense in safari because you are pushing newer things away to see older things.  In Firefox, you are not doing this.  You are moving forward and backwards through the history list, the directions of which are clearly indicated by the right and left interface arrows.  Firefox should adopt Safari's metaphor and show movement, or should use the same directions as shown in the arrows, but should not mix the two.  (An option to change this would be nice too...)

Comment 1

7 years ago
There's Bug 678392 for the swipe animation. Should we mark this as a duplicate of that?
Of course there's the other point of an option to change or disable that. I think I'll add a separate bug for that, unless I can find an existing bug for it.

Comment 2

7 years ago
Okay, it looks like bug 709484 is about disabling that functionality, and it won't be fixed because it's not a big deal for most people. :/
Yeah, given how this bug is written, it'd be fixed by bug 678392.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 678392
You need to log in before you can comment on or make changes to this bug.