Last Comment Bug 680361 - rm modules/plugin/
: rm modules/plugin/
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: Matheus Kerschbaum
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-19 00:01 PDT by Matheus Kerschbaum
Modified: 2011-08-22 11:18 PDT (History)
5 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (434 bytes, patch)
2011-08-19 00:04 PDT, Matheus Kerschbaum
jaas: review+
Details | Diff | Splinter Review
follow-up patch (1.14 KB, patch)
2011-08-21 18:05 PDT, Matheus Kerschbaum
jaas: review+
Details | Diff | Splinter Review

Description Matheus Kerschbaum 2011-08-19 00:01:27 PDT

    
Comment 1 Matheus Kerschbaum 2011-08-19 00:04:30 PDT
Created attachment 554322 [details] [diff] [review]
patch
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-08-21 11:32:52 PDT
http://hg.mozilla.org/mozilla-central/rev/279d6114667d
Comment 4 Jim Jeffery not reading bug-mail 1/2/11 2011-08-21 16:06:03 PDT
Latest hourly with the latest merge from MI to M-C is causing flash plugin to crash, turning off OOP causes browser to crash on start up if there is flash on the tab that is loading. 

Since its an hourly I'm not sure crash-reports will be of any value: 

https://crash-stats.mozilla.com/report/index/32583d7c-a907-46a7-a498-598322110821
http://crash-stats.mozilla.com/report/index/bp-88b80f0e-a995-4047-9e7c-c0d062110821

this is the only patch I 'think' that may have affected plugins, and not even sure what this patch is doing, so maybe its not the cause. 

Latest merge from mi->m-c based on cset:
http://hg.mozilla.org/mozilla-central/rev/482742e6fff7
some 73 patches, so finding the cause of the flash plugin crash is going to be fun.  

I am using flash 10.3.183.5 32 bit 


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110821 Firefox/9.0a1
Comment 5 Ed Morley [:emorley] 2011-08-21 16:48:00 PDT
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #4)
> this is the only patch I 'think' that may have affected plugins, and not
> even sure what this patch is doing, so maybe its not the cause. 

This patch just removed a no longer used file for xpcshell plugin tests (ie would only affect testing, not the builds), so won't have been the cause.

Perhaps the mozilla-inbound tinderbox builds can help narrow the range?
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-win32/
Comment 6 Ed Morley [:emorley] 2011-08-21 16:48:46 PDT
Matheus, have just spotted this:
http://mxr.mozilla.org/mozilla-central/source/testing/xpcshell/xpcshell.ini#8
...which can presumably be removed now too? :-)
Comment 7 Matheus Kerschbaum 2011-08-21 18:05:37 PDT
Created attachment 554777 [details] [diff] [review]
follow-up patch

(In reply to Ed Morley [:edmorley] from comment #6)
> Matheus, have just spotted this:
> http://mxr.mozilla.org/mozilla-central/source/testing/xpcshell/xpcshell.ini#8
> ...which can presumably be removed now too? :-)

Well spotted. Can you land this patch for me?
Comment 8 :Ms2ger (⌚ UTC+1/+2) 2011-08-22 03:17:08 PDT
And can we make that an error?
Comment 9 Ed Morley [:emorley] 2011-08-22 06:59:16 PDT
Follow-up:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ac57320746e8
Comment 10 Mounir Lamouri (:mounir) 2011-08-22 10:57:57 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/ac57320746e8
Comment 11 Ed Morley [:emorley] 2011-08-22 11:18:47 PDT
(In reply to Ms2ger from comment #8)
> And can we make that an error?

Filed bug 680980.

Note You need to log in before you can comment on or make changes to this bug.