Closed Bug 680565 Opened 9 years ago Closed 6 days ago

I was reading at the middle of the page, and the page got reloaded and brought to the top

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 220118

People

(Reporter: nicolas.barbulesco, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Hello,

Mac OS X 10.6.8 (10K549). Firefox 5.0.

In the prefs, I have ticked "Prévenir lorsque des sites Web tentent de rediriger ou de recharger la page" : "Warn when Web sites try to redirect or reload the page".

I was reading the article http://lexpansion.lexpress.fr/carriere/licenciee-pour-un-vol-de-poireaux-pourris_259374.html at the middle of the page, and the page got reloaded and brought to the top — because, you know, for these news sites, the world is moving 24/7, so any article you read has to be refreshed every 5 minutes, in case something new is interesting, like… a new loading of the ads. So I lost my reading.

I expect something else : a bar appears at the top, warns me "This page wants to reload itself.", and reloads the page only when I accept.

Thanks for correcting that.

Nicolas
WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110829 Firefox/9.0a1

After the page is reloading, it remains where it were before.

Try updating to the latest Firefox and see if the issue is still reproducing:
http://www.mozilla.org/en-US/firefox/new/
Considering comment1, setting resolution to Resolved WFM.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Depends on: redirect-warn
No longer depends on: redirect-warn
Depends on: useragent
Blocks: useragent
No longer depends on: useragent
No longer blocks: useragent
(In reply to Vlad [QA] from comment #1)

> WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a1) Gecko/20110829
> Firefox/9.0a1
> 
> After the page is reloading, it remains where it were before.

This would not be “working correctly”, this would just be “less worse”.

* The expected behaviour is : * 
A bar appears at the top, non-modal, asks me "This page wants to reload itself", and reloads the page only if and when I accept.

The W3C's Web accessibility guidelines forbid the current behaviour.

On some pages, the current user experience is particularly bad : I am watching a video and the auto-reload breaks it, and then when I find again my video it is stopped and back at its beginning.

And this is sometimes even worse : I am writing a comment on the article, and boom ! the article gets reloaded, and I have lost my writing. This is data loss.

On some pages, the auto-reload is every 1 minute !
Severity: major → critical
Status: RESOLVED → UNCONFIRMED
OS: Mac OS X → All
Hardware: x86_64 → All
Resolution: WORKSFORME → ---
This primary behavior in question here is the reload (which is not by itself critical), which in turn causes the comment to be lost.

I can't reproduce this on windows with http://www.lexpress.fr/emploi/licenciee-pour-un-vol-de-poireaux-pourris_1436781.html#article_comments

> On some pages, the auto-reload is every 1 minute !
please cite some URLs
Severity: critical → normal
Flags: needinfo?(nicolas.barbulesco)
Wayne, you should be able to reproduce the problem — or at least the reload and the data loss — with the page www.francetvinfo.fr/france/en-pleine-sortie-scolaire-un-lyceen-refoule-a-l-entree-d-une-centrale-nucleaire_538367.html
Flags: needinfo?(nicolas.barbulesco)

¡Hola Nicolas!

Is this still an issue on current versions of Firefox?

If so, could you please update the Status section of the Tracking Flags on this bug?

¡Gracias!
Alex

Flags: needinfo?(nicolas.barbulesco)

¡Hola Nicolas!

Further reviewing this looks to me like a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=220118

Could you please confirm and mark it as a duplicate if so?

¡Gracias!
Alex

No response, so let's mark it as a duplicate anyway.

Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago6 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 220118
Flags: needinfo?(nicolas.barbulesco)
You need to log in before you can comment on or make changes to this bug.