Save downloads to folders based on file type (i.e. mp3 files to Music folder)

RESOLVED DUPLICATE of bug 118924

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED DUPLICATE of bug 118924
7 years ago
5 years ago

People

(Reporter: AhmedKhattabShams@Gmail.com, Unassigned)

Tracking

5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622232052

Steps to reproduce:

Downloading 3 files with the following extensions:
.mp3
.doc
.wmv


Actual results:

Firefox places downloaded files to irrelevant directories to the downloaded file type:

saves .mp3 to 'Downloads' directory not to 'Music'
saves .doc to 'Downloads' directory not to 'Documents'
though it saves video files to 'Video' directory not to 'Downloads'


Expected results:

Downloading all file types to 'Downloads' Directory.
To avoid cluttering the folder, I suggest to create a tree of folders under 'Downloads' folder, like:
'Downloads/Video'
'Downloads/Audio'
'Downloads/Documents'
etc..
(Reporter)

Comment 1

7 years ago
This bug exists on Ubuntu 11.04, if it makes a difference.
Thanks

Updated

7 years ago

Comment 2

7 years ago
Firefox let's you specify where you download a file. Updated title and component based on how I read your request. If I got it wrong, let me know.
Severity: normal → enhancement
Component: Preferences → Download Manager
Product: Firefox → Toolkit
QA Contact: preferences → download.manager
Summary: Firefox places downloads to irrelevant directories → Save downloads to folders based on file type (i.e. mp3 files to Music folder)
(Reporter)

Comment 3

7 years ago
The 'browser.download.dir' key was pointing to my Videos dir, I didn't modify it by hand, it might be caused by some add-on.
At this point, I'd like to suggest creating a tree of dirs under 'Downloads'(ie. Downloads/Video, Downloads/Music and Downloads/Documents) then download manager saves each downloaded file to it's relevant location, just to avoid cluttering the 'Downloads' dir, and it can load slowly, if that dir contained a lot of items.

Anyway, thank you Tim.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 118924
You need to log in before you can comment on or make changes to this bug.