remove extra items in context menu for objects

NEW
Unassigned

Status

SeaMonkey
Composer
18 years ago
9 years ago

People

(Reporter: sujay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
using 2/7 build of netscape

1) launch netscape
2) launch composer
3) insert object(image/h. line/link/table/anchor)
4) right mouse click on object.

Notice these extra menu items which don't need to be there:

Select All
Remove all Text Styles
Remove Links (should only be here after you've created the link)

all platforms.

Comment 1

18 years ago
Select All should probably remain in the menu, the other options could remain in 
the menu, but should be disabled until such time where the selection pertains to 
 the choice.
Assignee: beppe → cmanske
Priority: -- → P4
Target Milestone: --- → mozilla0.9.1

Comment 2

18 years ago
Probably will never change.
There's definitely nothing wrong with allowing "Select All" all the time.
As far as removing styles and links, it is an expensive calculation to do each
time UI is updated -- e.g., it would have to be done for each of the known
inline styles throughout the entire selection. So we decided it was not a
problem to always show those commands.
Any disagreement about this from others?
Target Milestone: mozilla0.9.1 → Future

Comment 3

18 years ago
select all doesn't make sense if there isn't anything to select (imo)

as for the other commands, can't we do the "calculation" when the user pops up 
the context menu (rather than always showing them)?

btw, last I heard, in context menus items shouldn't be disabled, they should be 
removed

Comment 4

18 years ago
btw, this is similar (dependent?) on Simon's bug:  #29000

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 5

17 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 6

17 years ago
Please don't put "#" before bug number so we get a link! (e.g. bug 29000)

Comment 7

17 years ago
*** Bug 29000 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Assignee: cmanske → nobody
Status: ASSIGNED → NEW
Priority: P4 → --
QA Contact: sujay → composer
Target Milestone: Future → ---
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → EXPIRED
Bulk reopening incorrectly expired bugs - no activity does not constitute no bug - these need proper checking.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---

Updated

10 years ago
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.