Last Comment Bug 680642 - MacroAssemblerMIPS.h is included but missing
: MacroAssemblerMIPS.h is included but missing
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: Other All
: -- normal (vote)
: mozilla9
Assigned To: general
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-20 00:31 PDT by Mike Hommey [:glandium]
Modified: 2011-08-24 01:31 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
affected


Attachments
Don't enable YARR JIT on MIPS, as the implementation is missing (1.28 KB, patch)
2011-08-21 11:58 PDT, Mike Hommey [:glandium]
dmandelin: review+
Details | Diff | Review

Description Mike Hommey [:glandium] 2011-08-20 00:31:33 PDT
This is the build error I get when building 7.0 beta 1 on mips:
../../../js/src/assembler/assembler/MacroAssembler.h:46:32: fatal error: MacroAssemblerMIPS.h: No such file or directory

It looks like the upstream assembler was not imported fully. However, that include was already there before, and it didn't fail to build, so in fact, I guess this may well be another manifestation of bug 670719.
Comment 1 Mike Hommey [:glandium] 2011-08-20 09:18:47 PDT
It's actually not related to bug 670719.

The root problem is that js/src/assembler/wtf/Platform.h does a bunch of autodetections that override what is defined in js/src/Makefile.in, such as enabling jit on mips... and the jit file for mips is missing.
Comment 2 Mike Hommey [:glandium] 2011-08-20 09:56:34 PDT
For reference, this was caused by bug 625600
Comment 3 Mike Hommey [:glandium] 2011-08-21 11:58:45 PDT
Created attachment 554746 [details] [diff] [review]
Don't enable YARR JIT on MIPS, as the implementation is missing

This is the easy fix. The more elaborate fix would be to import the missing file from the webkit source.
Comment 4 Marco Bonardo [::mak] 2011-08-24 01:31:27 PDT
http://hg.mozilla.org/mozilla-central/rev/43669eae1968

Note You need to log in before you can comment on or make changes to this bug.