Update should offer to install add-on compatibility reporter before disabling a add-on

RESOLVED INVALID

Status

Thunderbird
Installer
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Eric Moore, Unassigned)

Tracking

6 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110816154714

Steps to reproduce:

The draft of the Thunderbird rapid release process at http://people.mozilla.org/%7Embanner2/tbdevspecifics/ states that AMO will automate updating the maximum version supported by an add-on when a new release is available, after checking that the add-on supported the prior version and doesn't use any APIs that disappeared in the new version of Thunderbird. The problem is nothing is done for add-ons only available from other web sites. It will be hit and miss whether those authors will update their add-ons every 12 weeks. This will cause a lot of support problems.

A significant number of users have at least one add-on that is not available on AMO. Most users don't know about the add-on compatibility reporter add-on or other ways to disable version checking. It would help if the update software also tried to help deal with the problems caused by the rapid release process, rather than relying completely upon AMO. This could be as simple as offering to install the add-on compatibility reporter add-on if it detects some add-ons that it plans on disabling.
The AMO team are currently debating about a add-ons default to compatible model [1] which would obviously greatly benefit non-AMO add-ons.

I'm marking this as invalid as I don't think that this is the right place to have a discussion on how we improve things for non-AMO based add-ons; the solution proposed is one possible option, but really needs to be discussed and considered before taking futher. Please either follow-up to the tb-planning thread, or it would probably be better to discuss on mozilla.dev.extensions where there's more of the right people watching.

[1] http://groups.google.com/group/mozilla.dev.extensions/browse_thread/thread/f68e4b67c18f037d#
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.