Closed Bug 680719 Opened 9 years ago Closed 9 years ago

Downloads window does not open when Firefox is on second monitor

Categories

(Firefox :: General, defect)

6 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 644733

People

(Reporter: tassadar, Unassigned)

Details

Reproducible: Always


Steps to Reproduce:

1. Open Firefox.
2. Move Firefox window to second monitor located to the left of primary.
3. Maximize Firefox.
4. Click the Downloads button on the toolbar or select the Tools > Downloads menu item.


Expected Results:

The Downloads window should appear.


Actual Results:

Nothing happens.


Other Thoughts & Findings:

This issue has only occurred on my mac so far. This operation functions normally on both ubuntu and windows environments.

The issue persists as long as the second monitor remains the start-up monitor for Firefox. This is the only way I was able to get the Downloads window to open.

Steps to resume normal operation once issue has occurred:

1. Open Firefox (If not already opened).
2. Move Firefox to primary monitor.
3. Maximize Firefox.
4. Restore Firefox.
5. Maximize Firefox.
6. Close Firefox.
7. Right-click the Firefox icon in the Dock.
8. Select Quit.

Steps 4 and 5 seem redundant, but Firefox still opens on the second monitor if they do not occur. This may be a different issue.

Steps 7 and 8 are necessary because opening Firefox at this point acts like a Firefox window is already open.

When Firefox is opened after this sequence, everything is back to normal.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644733
You need to log in before you can comment on or make changes to this bug.