Slowness/hang when saving images due to download history is unacceptable

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: t8av, Unassigned)

Tracking

6 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-10-25])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110811165603

Steps to reproduce:

I was trying to save an image to the local disk


Actual results:

Firefox hang (stopped working) for about a minute


Expected results:

The image should have been saved immediately without firefox being hang
(Reporter)

Comment 1

7 years ago
To solve the problem first I disabled all the add-ons. 
When it didn't work, I cleared firefox cache memory.
When it didn't work, I re-installed firefox.
When it didn't work, I used windows system restore to a few days back. 
At that point I read in the internet that the problem might be "download history" which is too long, so I cleared it and then everything came back to normal.

NO REASON IS GOOD ENOUGH TO CAUSE HANG IN FIREFOX WHEN SAVING IMAGES!!!!!
Please fix this problem using one of the following:
1. Auto-delete old entries of the download history (size limit for this list).
2. When saving an image, let firefox Write/Read the exiting list using a method which will not cause it to hang (there are many ways to do it).
3. when the user is trying to save an image, pop-up a warning message for the user to know that the delay is caused by a too-long download history.
Is your Issue reproducible in Safe-Mode using (a hopefully made Backup of) your downloads.sqlite File what showed the Issue?

https://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 3

7 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #2)
> Is your Issue reproducible in Safe-Mode using (a hopefully made Backup of)
> your downloads.sqlite File what showed the Issue?
> 
> https://support.mozilla.com/en-US/kb/Safe+Mode

No need to reproduce the issue - please see my comment above. I suggested few ways how to solve this Firefox bug.
If it is a Bug in Firefox itself at all. Maybe something in the past corrupted your download.sqlite File and Firefox exposes this Corruptness in above mentioned Way.

This happened in the Past for the places.sqlite File caused by Extensions behaving wrongly.

Can you Provide a Stacktrace of the Hang?
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
(Reporter)

Comment 5

7 years ago
(In reply to XtC4UaLL [:xtc4uall] from comment #4)
> If it is a Bug in Firefox itself at all. Maybe something in the past
> corrupted your download.sqlite File and Firefox exposes this Corruptness in
> above mentioned Way.
> 
> This happened in the Past for the places.sqlite File caused by Extensions
> behaving wrongly.
> 
> Can you Provide a Stacktrace of the Hang?
> https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

After I cleared the download history, the problem disappeared. It started after installing Real-player flash downloader and continued even after I uninstalled this extension and even after I uninstalled and installed firefox. So probably the problem is related to the download-history rather than the extension.

Comment 6

5 years ago
see this in current versions?
Flags: needinfo?(t8av)
Whiteboard: [closeme 2013-10-25]
(Reporter)

Comment 7

5 years ago
very old bug....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(t8av)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.