auto-fill is wrong when typing into location bar

RESOLVED DUPLICATE of bug 559878

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 559878
7 years ago
6 years ago

People

(Reporter: Andrew Weir, Unassigned)

Tracking

8 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
After a few hours use on a clean install, the location bar will have a variety of URLs in its cache.

If I then type in a full URL including protocol (typing: http), the address bar overwrites my guess (deletes my first key stroke and replaces it with 'w') - then allows me to keep typing with the wrong address entered (end result is: wttp)

1) Visit several sites to generate a small cache of URLs
2) Type in http
3) Location bar tries to guess a site beginning with www
4) End result in location bar reads wttp

The behaviour is repeatable and not consistent with previous versions of firefox, or any browser prior.

Version: 8.0a2 (2011-08-21)
If this is a Regression, can you find a Range?
http://harthur.github.com/mozregression/

I failed to repro :-/
(Reporter)

Comment 2

7 years ago
I'll take a look at this in a few hours and report my findings back to you. I will also take a video capture of the behaviour in action too, along with a more complete overview of addons etc being used.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559878
You need to log in before you can comment on or make changes to this bug.